Arduino MQTT


#1

Hello,

We are facing huge problems with the MQTT update. All old devices in Dashboard although they have automatically got MQTT username, password and clientID, configuring them in the arduino code and uploading to the board, in the dashboard its still pop ups the message for upgrade. So we have to remove all the old devices and all the sensors, actuators, etc we have configured.
Moreover when adding a new device with new MQTT username etc , i can not add for example an Generic Analog Input. When clicking “Add Sensor” button, its stays there for ever trying to add the widget. Also please tells under the “Channel” how we setup the virtual channel, by typing “V0” or just “0”?

Regards


#2

I have the same problem as you mentioned … :confused:


#3

Hi,

Thanks for sharing your findings.

  1. We’ll look into the “upgrade pop up” issue you’re facing.
  2. We’ll also look into the issue with adding a Generic Analog Input. I was able to duplicate that on my side as well.
  3. When adding a Virtual Channel, you can name it any number, for example “0”, so long as it matches on your code as well.

Thanks.
-Jesse


#4

What the code you are using? For the new mqtt arduino library, the widgets will automatically appear once the data is sent to the Cayenne dashboard. Kind of like this:

~Benny


#5

Hi @ufrtgr @benko.jaku ,

Try using the “Custom Widgets” :slight_smile: For channel you can just put the number, for example " 0 ".

~Benny


#6

Hello, as you can see i get some unexpected statements under Unit. Also Unit field is disabled and Step 2: Add Widget as well is disabled.


#7

@ufrtgr for sending data to cayenne dashboard from sensor or a value, you dont need to add a widget from dashboard.
use

    void loop() {
	Cayenne.loop();

	//Publish data every 10 seconds (10000 milliseconds). Change this value to publish at a different interval.
	if (millis() - lastMillis > 10000) {
		lastMillis = millis();
		//Write data to Cayenne here. This example just sends the current uptime in milliseconds.
		Cayenne.virtualWrite(1, x);
	}
}

where 1 is the channel and x is the value of the sensor data you want to send to cayenne dashboard. once you upload this code it will autoatically populate your dashboard with a widget. click on + to add it to your dashboard.


#8

it brings data, but it doesn’t solve all the problems. Why i can not add an analog sensor manual? Why those values have to come up by default? DHT22 sensor doesn’t work, wrong values come in the dashboard.


#9

Hello,
Where is the Integrated GPIO as it existed with the old version? How can we add relays?


#10

look at this for different data types https://mydevices.com/cayenne/docs_stage/cayenne-mqtt-api/#cayenne-mqtt-api-supported-data-types.

that is the procedure i guess.

what error are you getting? can you elaborate a bit more.


#11

Are you from Cayenne support?


#12

no. but been here for quiet a long time and very familiar with cayenne and team. i can help you with your problem.


#13

I cant add a custom widget as before. Simple i want to add a relay. Not possible after the MQTT update. I cant add DHT sensor, nothing works…


#14

this devices which are there in menu are MQTT added devices??


#15

Yes, i had to delete all my devices and have to add them from the beginning.


#16

can you a try new device with bring your own thing and follow the steps.


#17

We are unable to add custom widgets, we are unable to add analog sensors, we are unable to add relays, gpio etc.


#18

@ufrtgr can you try addding a new device from bring your own thing???


#19

I am sorry i can not understand what do you mean.


#20

on your dashboard go to add new > bring your own thing (blue color). click on it this will give you your MQTT credential. then add this credential into your code and uplaod it. this will add your device to your dashboard.
which arduino board and network shield you are using??