Arduino USB help


#21

It looks like the file is supposed to be in your user folder not in the program files so it probably just can’t find the file you are trying to run. Another guess is that the cayenne library is not installed correctly. Here are instructions for installing:

Sketch --> Include library --> Library manager. In the Library Manager search Cayenne, and install the library.


#22

This is almost certainly the Cayenne library not being installed, thus why the folder was missing in your initial command. That ‘WiFi’ library is unrelated to Cayenne and would not contain our USB Serial connection batch file.

Here is the output from my Windows machine once the library is installed:


#23

THANKS FOR HELP
now made the connections on bread board
arduino is online
but can’t enable to add sensor-stuck in the process of disabling and enabling connection scrpit


can not above ahead of this


#24

1.After arduino is online
2.To use thermister sensor I want to upload the sketch file to arduino;to do so I typed “Ctrl+c and then y in command prompt” (to enable connection script.)
3.after successfully uploading the file the dashboard is showing your arduino is offline

Please suggest what I’m doing wrong
i also re enable the connection script by typing “cayenne-ser.bat -c COM15”


#25

Please also suggest how to disable serial monitor in IDE


#26

Hi again. Yeah when using that Serial USB connection sketch, it is necessary to first disable the running cayenne-ser.bat script (with Ctrl+C), then upload any new code via Arduino IDE, then re-enable that script. At that point the Arduino should connect and show online again. This is because the Serial USB connection blocks the serial port that the IDE would use to communicate with the Arduino device.

I don’t think you need to do anything special to disable the Serial Monitor in the Arduino IDE – at least I have never done this despite using that sketch all the time. Just make sure you don’t have any lines like

#define CAYENNE_PRINT Serial or Serial.begin(9600); in your sketch, and comment them out or remove them if you do.

If it’s still showing as offline and you’ve uploaded new code and restarted the cayenne-ser.bat sketch, perhaps the first things I’d check are are that COM15 is still the port the Arduino is connected to (you can verify this in the Tools menu of the Arduino IDE) and that your token still matches the dashboard entry that you’re looking at.

Perhaps you can share the output from the cayenne-ser.bat script if you’re still stuck trying to connect?


#27

Thanks so much for help!
Now was able to connect the sensor and getting the readings on dashboard

For my project I want to send data to cloud at 500 samples/sec (500 Hz) and want to access real time data in graphical format so could you please suggest the solution.


#28

Hi @kasliwal.mehul333,

I’m glad you got your project up and running. You can use a history graph widget to view data in a graphical format.

Cheers,

-Benny


#29

Can I use cayenne to send data to dashboard at 500 samples/sec (500 Hz)


#30

Also want to enquire that there is no Cayenne MQTT example for serial usb connection
(i.e;
File->examples->cayenneMQTT->connections)
Please suggest the solution


#31

please help me :!

why “COM8” not recognized?


#32

You’re in powershell there, you want to open cmd


Arduino Serial USB Connection problem