Bug Filed on 01-19-2016: Pi > Options Toggle i2C button to make i2C work?


#1

1. What OS? (Wheezy or Jessie)

Rasparian Wheezy

2. What class/size SD card? (ex. class 10 16gb)

8G ‘good’

3. What Model Pi? (A+, A, B+, B, Pi2)

Pi 2

4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

Trying to enable i2C and a pressure sensor.

Hi

I am having a go at adding the Barro Pressure sensor and have been trying to turn on i2C and get things working. What is the correct sequence here ?

I have tried to toggle the i2C button in the Options panel and the message comes up:

Not sure if this is relevant or I am doing things the wrong way around.

  • Do I need to toggle the switch at all ?
  • Should it stay toggled ON
  • Does ‘We need to’ mean it will reboot automatically (from your end) or do I have to re boot the Pi at my end via the dashboard etc ?
  • As soon as I refresh or go away from the page the toggle goes back to i2C = OFF (So I imagine nothing gets changed or stored)

As per idea about some basic videos on how to use Cayenne… Sorry to nag… I am pretty much guessing my way around here. Happy to try anything out or do things differently if you want me to test stuff out.

Feel free to delete this post if it is way off beam…

~ Andrew


#2

Hi Andrew,

I create two videos today and will be creating many more :slight_smile:

You shouldn’t need to mess with the I2C settings. We haven’t fully implemented the ability to edit the settings.

If you connect the BMP180 to I2C pins, then all you should need to do is add the widget. I’ve connected a ton of them, so reach out if you are having issues. I just timed myself and was able to install myDevices agent and get a BMP180 & LED light connected to my dashboard in 7 mins 5 secs. This was using wifi dongle too!

So yeah, you should need to enable / disable I2C after you install Cayenne, we enable it for you. Videos coming, was gone all last week at CES. hang in there!

-B


#3

Thanks…
A few moments later…


:smile:
AND

~ Andrew


#4

Nice!