Bug Filed on 02-22-2016: myDevice causing disk to fill up


#1

Has anyone else found that when myDevices is running on a raspberry pi that it causes a huge amount of information to be logged to /var/log/SystemInformation.log

When it is running about 1Mb is logged every 5 mins, when it is not running practically nothing. Only noticed when disk got to 99% full after myDevices had been running for about a week and the log file was nearly 2Gb


#2

Yes that is happening to me. Running pi zero with 16 Gb sd card. Only running 3 days, started out at 32% disk full now up to 82% full!


#3

Thank you for reporting this we apologize for the inconvenience and we are actively working on a fix for this issue we will let you know when we have a fix.

Thanks
Sumeet


#4

My SD card is now almost full. Can I just delete the /var/log/SystemInformation.log?

And how to turn off the logging?

Thanks!


#5

Hi guys,

We have some fixes for that and will be delivered with next build.
You can add in /etc/MyDevices/crontab.sh some lines:

rm -rf /var/log/SystemInformation.log
rm -rf /var/log/daemon*


#6

@stevev4772 @steviebald Moving this to the ‘Resolved’ category. Please let us know if this issue comes up again.


#7

Strange things go on…

crontab.sh is present in /etc/MyDevices/

rm -rf /var/log/SystemInformation.log
rm -rf /var/log/daemon*’

those lines are already in the end of crontab.sh

I am sorry to inform you that the problem persists, as the disk is still slowly getting filled up, even if the above contitions are met.