Bug Filed on 02-25-2016: Install fails in Installing myDevices agent


#21

If you are only using 1.3G then you definitely have the lite version. Full version is around 3G with nothing else installed.


#22

Thanks @ats1080s.

@kay you can download the full version here https://www.raspberrypi.org/downloads/raspbian/


#23

Thank, is it possible to upgrade to the full version without reinstalling??
Hope that thats possible.


#24

Check this out :slightly_smiling:


#25

I kept getting this on one of my A+ pi’s running Jessie Lite… turned out that because I had customised /tmp it wouldn’t install either due to size requirements. I had set /tmp at 50MB using tmpfs (RAMDISK) and thus it would not install (required 200MB). A+ only has 256MB total so I had to remove my ramdisk /tmp… run the install and then reinstate.

I use this so that I can dump text into RAM instead of the SD card, thus increasing its life.

I guess I could also have hacked the setup.sh to use a different path too.


#26

Hello, same issue here. i want to install on a working piaware from flight aware unit that i have already running outside, to add some sensors.
pi@piaware ~ $ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 7.2G 2.3G 4.6G 33% /
devtmpfs 214M 0 214M 0% /dev
tmpfs 44M 244K 44M 1% /run
tmpfs 5.0M 0 5.0M 0% /run/lock
tmpfs 22M 0 22M 0% /run/shm
/dev/mmcblk0p1 56M 20M 37M 36% /boot
tmpfs 22M 4.0K 22M 1% /tmp

System hostname piaware (127.0.1.1)
Operating system Debian Linux 7.11
Webmin version 1.810
Time on system Fri Aug 12 15:34:56 2016
Kernel and CPU Linux 4.1.19+ on armv6l
System uptime 0 hours, 11 minutes
Running processes 78
CPU load averages 1.40 (1 min) 1.00 (5 mins) 0.52 (15 mins)
CPU usage 81% user, 19% kernel, 0% IO, 0% idle
Real memory 98.54 MB used, 434.94 MB total

Local disk space 2.62 GB used, 7.16 GB total

i did the raspi config resize thing, and rebooted, but still stuck at install.
any pointers to fix this?
thanks!


#27

Welcome to Cayenne!

Looks like you’re running wheezy which isn’t supported any more. You will have to upgrade to Jessie to get Cayenne installed.


#28

Hi! Have the same Setup requires at least 200Mb for install problem on piaware image based on Raspbian GNU/Linux 8.0 (jessie) on Rasberry Pi 3:

pi@img-1e:/$ uname -a
Linux piaware 4.4.0-1-rpi2 #1 SMP Debian 4.4.6-1+rpi14 (2016-05-05) armv7l GNU/Linux


pi@img-1:/$ cat /proc/version
Linux version 4.4.0-1-rpi2 (debian-kernel@lists.debian.org) (gcc version 4.9.2 (Raspbian 4.9.2-10) ) #1 SMP Debian 4.4.6-1+rpi14 (2016-05-05)


pi@img-1:/$ lsb_release -a
No LSB modules are available.
Distributor ID: Raspbian
Description:    Raspbian GNU/Linux 8.0 (jessie)
Release:        8.0
Codename:       jessie


pi@img-1:/$ cat /etc/os-release
PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL="http://www.raspbian.org/RaspbianBugs"


pi@img-1:/$ df -h
Filesystem      Size  Used Avail Use% Mounted on
udev             10M     0   10M   0% /dev
tmpfs           185M  4.7M  181M   3% /run
/dev/mmcblk0p2  7.2G  1.8G  5.1G  26% /
tmpfs           463M  4.0K  463M   1% /dev/shm
tmpfs           5.0M     0  5.0M   0% /run/lock
tmpfs           463M     0  463M   0% /sys/fs/cgroup
tmpfs           463M   19M  445M   4% /tmp
/dev/mmcblk0p1  128M   55M   73M  43% /boot
tmpfs            93M     0   93M   0% /run/user/1000

This is what I get after sudo bash rpi_XXXXXXXXXXX.sh -v:

...
+ set -x
+ exec
(0%)
Thu May  4 15:18:49 MSK 2017 Installing myDevices agent
0
(-1%)
Thu May  4 15:18:52 MSK 2017 Installing myDevices agent
Setup requires at least 200Mb for install

Any idea to fix it?


#29

Have a look at this thread Unable to install on raspberry pi 3

Basically the problem is that you have a non-default partition layout so you’ll have to modify the installer script to match what you have.


#30

Thank you, it helped! Have changed

availableSize=df -k | head -2 | tail -1 | awk '{print $4}'

to

availableSize=df -k | head -4 | tail -1 | awk '{print $4}'

and commented out downloading and extracting myDevices-1.0.tar.gz in rpi_XXXXXXXXXXX.sh preventing overwrite my changes in myDevices-1.0/setup.sh.


#31

@rsiegel might be worth redoing the installer to handle this a bit better.


#32

I am having similar issues.
my df-h
pi@raspberrypi:~ $ df -h
Filesystem Size Used Avail Use% Mounted on
/dev/root 27G 4.6G 21G 18% /
devtmpfs 460M 0 460M 0% /dev
tmpfs 464M 0 464M 0% /dev/shm
tmpfs 464M 6.3M 458M 2% /run
tmpfs 5.0M 4.0K 5.0M 1% /run/lock
tmpfs 464M 0 464M 0% /sys/fs/cgroup
/dev/sda6 68M 22M 47M 32% /boot
tmpfs 93M 0 93M 0% /run/user/1000
/dev/sda5 30M 446K 28M 2% /media/pi/SETTINGS

Running
pi@raspberrypi:~ $ cat /etc/os-release
PRETTY_NAME=“Raspbian GNU/Linux 9 (stretch)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“9”
VERSION=“9 (stretch)”
ID=raspbian
ID_LIKE=debian
HOME_URL=“http://www.raspbian.org/
SUPPORT_URL=“http://www.raspbian.org/RaspbianForums
BUG_REPORT_URL=“http://www.raspbian.org/RaspbianBugs

Always stops at
./myDevices-1.0/3rd_party/suds-jurko-0.6.tar.gz

  • set -x
  • exec
    (0%)
    Wed Apr 4 18:10:39 ADT 2018 Installing myDevices agent
    Any Ideas