Bug Filed on 03-28-2016: Scheduled restart fails


#1

Hi

One-day old newbie to Cayenne, but have already achieved much more with this platform than in a couple of months of frustration with some of the alternatives :smiley:

However, the scheduled daily restart event I’ve set up with the IOS app has failed so far…

I’ve pasted a few lines from the myDevices log below, around the time of the scheduled restart (daily @ 23:00). Happy to provide the complete log but it’s already 1Mb, after just 24 hrs…

Any thoughts on what’s happening?

Cheers, Christian

2016-03-25 22:56:47 - myDevices - WARNING - DownloadSpeed TestUpload - Not implemented
2016-03-25 22:56:48 - myDevices - WARNING - Packet type not implemented: 37
2016-03-25 23:00:11 - myDevices - ERROR - SendMessage:<urlopen error [Errno -2] Name or service not known>
2016-03-25 23:00:11 - myDevices - WARNING - DownloadSpeed TestUpload - Not implemented
2016-03-25 23:00:13 - myDevices - ERROR - SendMessage:<urlopen error [Errno -2] Name or service not known>
2016-03-25 23:00:13 - myDevices - WARNING - DownloadSpeed TestUpload - Not implemented
2016-03-25 23:00:18 - myDevices - WARNING - Packet type not implemented: 37
2016-03-25 23:00:34 - myDevices - ERROR - SendMessage:<urlopen error [Errno -2] Name or service not known>
2016-03-25 23:00:34 - myDevices - WARNING - DownloadSpeed TestUpload - Not implemented
2016-03-25 23:00:36 - myDevices - ERROR - SendMessage:<urlopen error [Errno -2] Name or service not known>
2016-03-25 23:00:36 - myDevices - WARNING - DownloadSpeed TestUpload - Not implemented
2016-03-25 23:00:40 - myDevices - WARNING - Packet type not implemented: 37
2016-03-25 23:01:25 - myDevices - WARNING - DownloadSpeed TestUpload - Not implemented
2016-03-25 23:01:35 - myDevices - WARNING - Packet type not implemented: 37
2016-03-25 23:11:48 - myDevices - WARNING - Packet type not implemented: 37
2016-03-25 23:22:42 - myDevices - WARNING - DownloadSpeed TestUpload - Not implemented
2016-03-25 23:26:48 - myDevices - WARNING - Packet type not implemented: 37
2016-03-25 23:41:48 - myDevices - WARNING - Packet type not implemented: 37
2016-03-25 23:43:43 - myDevices - WARNING - DownloadSpeed TestUpload - Not implemented
2016-03-25 23:56:48 - myDevices - WARNING - Packet type not implemented: 37


#2

Hi Christian,

Welcome to the Cayenne Community. We’re glad you’re using Cayenne and enjoying it’s capabilities. We’re going to be implementing some very cool features upcoming as well, like Arduino integration, custom code insertion, mutliple new widgets (like video streaming / picture upload), and others.

So this is a known issue with the logs we are generating. We have a fix ready and are waiting to deploy it out during one next release…sorry about this.

Linking the other post that references this too: Bug Filed on 03-14-2016: Packet type not implemented: 37

-B


#3

Cool, thanks for your swift feedback, @bestes. Any thoughts on what may be causing the scheduled restart to fail?

Cheers, Christian


#4

Unfortunately, not at the moment. Does creating the restart through web dashboard work? (You don’t have to try this, but would help determine if this is iOS app bug or general scheduler bug).

-B


#5

I’ve now deleted the original scheduled event in the web browser and added a new one, also in the browser, and the RPI restarted at the right time :slight_smile: It actually rebooted twice, but better with a couple of restarts, rather than none!

So it looks as though this may be an IOS issue, as that’s where I added the schedule in the first place.

Update: the email alert on reboot didn’t happen.

Cheers, Christian


#6

Hey Christian,

Thanks for helping us narrow down the issue. We’ll see if we can reproduce it with iOS and then get a fix scheduled.

Since this looks like a bug, I’m going to move this topic to the Bugs / Issues category.

-B