Bug Filed on 04-14-2016: Çayenne continuously shows Pi as Offline


#1

What dashboard are you using? (Web, iOS, Android)
Web


What OS? (Jessie, Wheezy)
Jessie


What Model Pi?

B model 1


Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

I was busy at work and didn’t rin my Pi/Cayenne for a couple of weeks. Yesterday connected, but Cayenne dashboard shows Pi offline, though I’ve left it for the whole day. On the same laptop I can ping and ssh to the Pi, from Pi itself I can resolve cayenne’s URL and traceroute to it:

<<<==== Quote
`mypi:~ $ nslookup cayenne.mydevices.com 8.8.8.8
Server: 8.8.8.8
Address: 8.8.8.8#53

Non-authoritative answer:
Name: cayenne.mydevices.com
Address: 52.4.134.119
Name: cayenne.mydevices.com
Address: 54.175.254.195

mypi:~ $ traceroute cayenne.mydevices.com
traceroute to cayenne.mydevices.com (52.4.134.119), 30 hops max, 60 byte packets
1 10.84.62.1 (10.84.62.1) 0.408 ms 0.313 ms 0.330 ms
2 41.191.198.189 (41.191.198.189) 0.503 ms 0.487 ms 0.481 ms
3 41.191.199.242 (41.191.199.242) 0.598 ms 0.599 ms 0.597 ms
4 196.201.222.62 (196.201.222.62) 1.235 ms 1.311 ms 1.309 ms
5 195.50.120.5 (195.50.120.5) 138.628 ms 138.674 ms 138.687 ms
6 * * *
7 4.79.22.74 (4.79.22.74) 213.663 ms 211.367 ms 211.526 ms
8 * * *
9 * * *
10 54.239.110.205 (54.239.110.205) 212.903 ms 54.239.110.229 (54.239.110.229) 229.113 ms 54.239.110.235 (54.239.110.235) 241.308 ms
11 54.239.110.59 (54.239.110.59) 216.439 ms 54.239.111.67 (54.239.111.67) 212.963 ms 54.239.111.73 (54.239.111.73) 212.729 ms
12 205.251.244.219 (205.251.244.219) 212.984 ms 205.251.244.193 (205.251.244.193) 215.220 ms 205.251.244.189 (205.251.244.189) 212.130 ms
13 * * *
14 * * *
15 * * *
16 * * *
17 * * *
18 * * *
19 * * *
20 * * *
21 * * *
22 * * *
23 * * *
24 * * *
25 * * *
26 * * *
27 * * *
28 * * *
29 * * *
30 * * *
<<===== End Quote

What could be a solution to this?


#2

I seem to get this from time to time as well. In fact the other day I plugged in my Pi after being unplugged for a while and it was showing as offline. If you still have the .sh installer just run that again and it should update everything for you and bring it back online.


#3

I think @ats1080s has the first step to solving this.

My thinking: We had a pretty nasty bug a couple weeks where the agent that was installed on your Pi would show as offline. We have since released fixes. Since your Pi was still using an old agent and could not connect to myDevices cloud, it could not update to the improved agent.

My hope is this will be fixed once you run the installer again. It’s the sudo sh rpi_xxxxxxxxx -v text, where rpi_xxxxxxxxxx is your unique install.

Please let us know if this fixes it!

-B


#4

Thanks for advice, Adam and Benny, unfortunately even after running the sh installer, for that last 3 hours it still shows off-line…Any ideas what could be wrong?


#5

What’s your agent version? (It’s in the configuration section on upper blue bar).

-B


#6

Agent version: 1.0.0.18542


#7

I seem to be having the same issue. I ran the installer again, but no luck. The installer said it was installing 1.0.0.19003. The web agent says 1.0.0.18727. Same situation, mine’s been off for a few weeks, turned it on and it’s not connecting.


#8

I noticed my pi had gotten a new IP address from my router, the android app still showed the old address which wouldn’t connect. So I statically assigned the old IP… no change. I can’t connect from either the web dashboard or the android app. It would be helpful if we had something to ping from the pi for testing. At this point I don’t know where else to go but a complete reload.


#9

I was able to resolve this in my case. It turns out at some point my id changed in “/etc/myDevices/AppSettings.ini”. I’m not sure if it was the original problem, or a result of running the installer again. I edited “/etc/myDevices/AppSettings.ini” changing it back to the old id, which I got off the web dashboard, “cayenne.mydevices.com/cayenne/dashboard/raspberrypi/ V03-XXXXXXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX”.


#10

@jhovak

J,
Very glad to hear you were able to solve your problem! I’m sorry you didn’t get much response from the group, but in my case I couldn’t figure what might be wrong. Very much appreciate that you took the time to explain what you had, what you did, and that you found a resolution. Now we have your experience available should we find ourselves in similar situation.

thanks,

Ian


#11

Very glad indeed!

@jhovak thanks you so much for providing the resolution steps and investigating! This should not have happened, I’ll bring this up to the team tomorrow (Monday) and once I can provide more info as to our fix I’ll update this thread.

@mac_ha Perhaps try jhovak’s work around until we can spend time investigating???

Thanks again @jhovak , and sorry about the inconvenience.

-B


#12

Yes, definitely will try tomorrow - I’ve left my Pi in the office - great if this is the fix!


#13

Thank you very much, @jhovak, it really works, I’m online now!!


#14

I have a similar problem. My solution was to ‘sudo nano /etc/resolv.conf’ and make sure I had a legitimate dns server ip there. Typically, I’ll find the internal ethernet base ip of 192.168.137.1 and replace it with OpenDNS’s 208.67.222.222. Unfortunately, the change reverts under some unknown condition and I have to redo periodically.
I ping ‘www.google.com’ and if the connection times out or something less than a millisecond count occurs, I know to redo the edit. I’m next going to try the ‘chown’ command on the file to see if that makes the edit permanent.


#15

Thanks for sharing, keep us updated with your progress here :slight_smile:
-B


#16

I used the ‘chown’ command to make pi the owner of /etc/resolv.conf and haven’t had any problems since.


#17

Just FYI,
I have my Pi3 setup through a wireless repeater and it has been working fine for more than a month.
Today I moved the Pi3 to the basement and it connected directly to the router’s wireless connection (not though the repeater) with the same IP address.
As mentioned above, everything was working, except for Cayenne web and Android constantly showing “offline”. I checked the “/etc/myDevices/AppSettings.ini” settings and they had NOT been changed.
Only after forcing the Pi3 to use the original (much weaker) wireless repeater signal, could I get it back to work.

Is there something else I can try?


#18

Hmmm, can you check out this post and see if everything checks out?