Bug Filed on 12-04-2015: HTTP(s) on port 8080 is sometimes blocked by enterprise firewalls


#1

Hi all,

I just signed up for the A-Team program and created my developer account. I’m doing this from my enterprise desktop. After successful login, I see an empty page.

The behaviour ist the same for IE and Firefox so it appears to be nothing browser-specific. A brief look at the HTML source code showed that you try to open a HTTP(S) connection using port 8080. It looks to me like this port is blocked.

Retrying this again from my private mobile phone at least showed me the first-visit step-1 page, so it looks to be the reason above.

Best,
Andreas


#2

Hi Andreas,

Thanks for letting us know. I’m going to move this to our Bugs / Issues category so our QA team can look at this, and will be sure to update this thread once resolved.

-B


#3

Andreas,

Would be helpful if you could give us the URL of the empty page you saw when logging in from enterprise desktop.

-B


#4

Benny,

the called URL after login is:

https://cayenne.mydevices.com/cayenne/dashboard/start

I still see an empty page.

The suspected call looks to be this one (I deleted all HTML tags):

        script src="https://cayenne-mydevices.vcom.com:8080/socket.io/socket.io.js

Port 8080 is blocked. So it looks like WebSockets via socket.io will cause problems in restricted environments.

  • Andreas

#5

Hi Andreas,
Glad to see you there !
And very nice find :smile:
Thanks !

Eric.


#6

Hi Andreas,

I think this issue is out of scope for us, since it’s network issue on your enterprise desktop, and it looks like you have no trouble accessing from a private network.

Can you let me know if you think this is in our scope? …moving this to Resolved.

Thanks,

~B


Document requirierendes/restrictions