Bug Filed on 12-21-2015: Generic DO Setting Up Issues and Observations


#1

1. What OS? (Wheezy or Jessie)

Wheezy

2. What class/size SD card? (ex. class 10 16gb)

8, C10

3. What Model Pi? (A+, A, B+, B, Pi2)

Pi2

4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

General erratic Generic DO operation. I am tinkering with the outputs and have some nasty 3V piezo sounders on various pins safely up safely at the other end of the house and down stairs…

Setting Up:

  • I see channels be set to IP or OP via the GPIO screen tab. Is this the intention ? Suggest that if a Pin ‘Channel’ is selected via the genergic IP or Generic OP path that the IP/OP status of that pin could be selected / set automatically via that process. I now know this but it was not clear.

Observations:

  • Here are some screen grabs but generally I am having to tab out to the GPIO screen and back sometimes without even doing anything else to hurry along the ON:OFF state change.
  • Deep and meaningfully… Who is boss or which has priority and when and what is the state change if we have the GPIO screen OR the Dashboard or even both open on tabs side by side. I imagine it is the most recent event (click/tap) IF WebIOPi is open on the LAN or even localhost will this confuse things, create confusion or again is it just all three methods working in parallel and ‘most recent event’
  • Sometimes when setting up Generic DI/DO the “Please Fix the Following Errors…” ( which I have not been able to do ) comes up other times it is just a case of half lite until you get it all correct.
  • Suggestion: Perhaps in final version some sort of a ‘active note’ help bubble could come up to guide the lost, notationally or logically impaired. This could be default for starters once beyond ‘helper mode’
  • GPIO Screen ‘Error sending command’ message worked very occasionally the rest of the time things were just very slow.
  • Will retest and let you know if any different on Tiny 7 box I have set up in shed.

Screen shots anyway…



~ Andrew


#2

@svazir @akaranfilian this is also testable. Let’s look into this.


#3

Hey Andrew,

Were you using WiFi dongle here?


#4

Cable connect of 2 x Pi into a router > Router cabled into an Open Mesh network on section here. Open mesh into a cable service.

Thoughts ?
I am happy to test / compare things here
E.g. connect the 2x Pi direct into the telco cable router

~Andrew


#5

Ping trcert from the Pi thru to your servers etc…
e-mail me direct any time for login, pwerd etc


#6

Resolving this per separate topic post discussion.