Bug Filed on 12-21-2015: Install fails on RPI with Jessie due to missing python 3.4 headers


#1

1. What OS? (Wheezy or Jessie)


Jessie

2. What class/size SD card? (ex. class 10 16gb)

8gb

3. What Model Pi? (A+, A, B+, B, Pi2)

B

4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

After running the install script which appeared to complete ok and moving to step 3 https://cayenne.mydevices.com/cayenne/dashboard/first-visit/step-3

the web page showed Libraries Installed but the Agent indicator was the progress image for over 10 minutes

Rebooted RPi but still the same on the web page.

Ran install script with --verbose and got the following output:

  • cd /tmp/myDevices-1.0
  • chmod +x /tmp/myDevices-1.0/setup.sh
  • /tmp/myDevices-1.0/setup.sh -code yt0qbjwetn --verbose
    (0%)
    Mon 21 Dec 18:20:51 AEDT 2015 Installing myDevices agent
    Mon 21 Dec 18:20:52 AEDT 2015 Installing system libraries
    Mon 21 Dec 18:20:52 AEDT 2015 Installing python3-dev
    (2%)
    Mon 21 Dec 18:20:55 AEDT 2015 Installing debian package: libpython3.2_3.2.3-7_armhf.deb
    (4%)
    Mon 21 Dec 18:21:06 AEDT 2015 Installing debian package: libssl1.0.0_1.0.1e-2+rvt+deb7u17_armhf.deb
    (6%)
    Mon 21 Dec 18:21:10 AEDT 2015 Installing debian package: libssl-dev_1.0.1e-2+rvt+deb7u17_armhf.deb
    (8%)
    Mon 21 Dec 18:21:13 AEDT 2015 Installing debian package: libexpat1_2.1.0-7_armhf.deb
    (10%)
    Mon 21 Dec 18:21:16 AEDT 2015 Installing debian package: libexpat1-dev_2.1.0-7_armhf.deb
    (12%)
    Mon 21 Dec 18:21:34 AEDT 2015 Installing debian package: python3.2-dev_3.2.3-7_armhf.deb
    Mon 21 Dec 18:21:36 AEDT 2015 Found Python 3.4.2…
    (80%)
    Mon 21 Dec 18:21:36 AEDT 2015 Copying agent libraries
    (85%)
    Mon 21 Dec 18:21:51 AEDT 2015 Installing python utils
    (90%)
    Mon 21 Dec 18:21:55 AEDT 2015 Installing agent
    Mon 21 Dec 18:21:57 AEDT 2015 Cannot install for Python 3.4.2 : missing development headers\n
    Mon 21 Dec 18:21:57 AEDT 2015 Finished agent code
    Mon 21 Dec 18:21:57 AEDT 2015 ERROR: myDevices cannot be installed - please check errors above

On trying to install python 3.4 headers got the following:

sudo apt-get install python3.4-dev
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt-get -f install’ to correct these:
The following packages have unmet dependencies:
libpython3.2 : Depends: python3.2 (= 3.2.3-7) but 3.2.4-1+b1 is to be installed
python3.2-dev : Depends: python3.2 (= 3.2.3-7) but 3.2.4-1+b1 is to be installed
python3.4-dev : Depends: libpython3.4-dev (= 3.4.2-1) but it is not going to be installed
Depends: libpython3.4 (= 3.4.2-1) but it is not going to be installed
E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

Did a apt-get -f install and after that able to install python 3.4 dev.

Rerun install script and the RPi appears on the web page.
Considering that Jessie comes with Python 3.4 by default, why is the myDevices setup installing 3.2 dev dependencies instead of 3.4 dev dependencies?


Unofficial Workaround for Jessie Lite! [EDIT: Jessie Lite now supported
#2

@svazir @akaranfilian Please import so we can create a card and look into this.

@tdeleanu Tagging you so you’re aware.


#3

I believe we’ve fixed this…please let me know otherwise.

-B


#4

I had a similar experience trying to get started. Since I started the install with the wrong OS, I may have to start from scratch and wipe the SD clean. However, let me explain my current situation.

Got Jessie installed and went to run the install script. The first error that came back (and surprised me) was it could not find Python. Got Python installed and re-ran the installer script. I then get the header error the above poster mentioned. Followed his lead for fixes, and re-ran the installer script.

However, at this point, I get good check marks on the installation except for an infinity spinning wheel on “ReBooting Pi.” I cannot seem to do anything to correct this.


#5

Hello just sharing my experience

I have a pi with Flightaware´s release 3, i had version 2 and could not get cayenne on it

on version 3 it failed for python, so i manually sudo apt-get install python3 plus a fix
ran the cayenne installer again and it went thru, but failed for
ERROR: WebIOPi cannot be installed - please check errors above
creating build/temp.linux-armv6l-3.4/native

arm-linux-gnueabihf-gcc -pthread -DNDEBUG -g -fwrapv -O2 -Wall -Wstrict-prototypes -g -fstack-protector-strong -Wformat -W error=format-security -D_FORTIFY_SOURCE=2 -fPIC -I/usr/include/python3.4m -c native/bridge.c -o build/temp.linux-armv6l-3. 4/native/bridge.o
Build for Python 3.4.2 failed

then the pi rebooted
tried to install webIOpi by hand with no luck.