Bug Filed on 12-21-2015: SD become full in few hours


#1

1. What OS? (Wheezy or Jessie)


Wheezy

2. What class/size SD card? (ex. class 10 16gb)

class 10 8 Gb

3. What Model Pi? (A+, A, B+, B, Pi2)

B+


4. Please describe the bug / issue. Attaching any relevant screenshots would be very helpful! Thanks in advance.

I notice that my SD Card becomes full in few hours…
That’s why i found some log file in /var/log, called myDevices.log.(date)…
i need to erase all this file otherwise my Rpi dont work…

As you can see in attached screenshot,
in yellow rectangle SD situation before remove…
in blue rectangle 4 file in object
in red rectangle file removed
in white rectangel situatione after removing that file…

Link to picture:

How can i resolve it!?


#2

There is supposed to be a fix soon for this, just wait it out. Not sure if we will have to manually delete wqhat we have or if the update will do it?


#3

Just checking but…
Did you choose option 1 in sudo raspi-config from the command line menu ?
This is like aka the Pi BIOS Settings to expand the file system to maximise the available real estate on the SD card ?
I think I heard Pi default OS assumes there is just 4G total. I am Not an expert on this…
Try it and see what the difference is or if it fixes things ?
This could be an auto set-up feature ?
~ Andrew


#4

Andrew does have a point. Your post indicates you have a 8GB SD card but your screen shot says you have a 4GB partition. Try resizing your partition


#5

sudo raspi-config
from the command line menu
Option 1
Exit and choose re-boot

While you are at it make sure you have all the penguins up to date and in a row…
sudo apt-get update
sudo apt-get upgrade
Choose Y
Come back in 15 minutes
reboot etc

This should be included in the ‘setting up your hardware’ part of the manual or tutorial etc.

~ Andrew


#6

We should no longer be storing logs on your Pi. @ftvplant Let me know if expanding the file system resolves issue. Also, think you could email me your login information so we can ‘look under the hood’?

@akaranfilian Let’s see what happens when we don’t expand the file system and use myDevices Cayenne.


#7

SD is allraedy axpand…
This is what i found this morning…

As you can see, SD is Full!!

In Red rectangle how large is… in yellow memory used…= available 0!!!

I have to remove software… some program crash for this issue…

How i can?!


#8

Ah, yes sorry I missed the fist column which is your total size. I usually use df -h so that format is a little different than what I am used to. If you have no need for logs you can set up a cron job to delete all log files every hour until this is fixed.

First switch to root user to avoid permission issues: sudo su
Then create the cron job: crontab -l | { cat; echo “0 * * * * rm /var/log/myDevices.log*”; } | crontab -

After that type in exit to get back to your regular pi account and you’re good to go.

To delete the cron job switch back to the root account with sudo su and use the command crontab -e then delete the line we added and save it.


>95% memory usage after one day consistantly
#9

@ftvplant is this still happening?