Can not add my RPi


#1

Hi,
I am trying to add my RPI3 into dashboard, I get no error message, agent is installed and running (both when starting on boot and when it is started manualy). I tired to install it using downloaded script and also using mobile app. Device gets restarted, instalation also without any error and nothing happens with dashboard.

debug log:
root@malina:/etc/webiopi# webiopi -c ./config -d
2017-11-15 15:25:02 - WebIOPi - INFO - Starting WebIOPi/0.7.23/Python3.4
2017-11-15 15:25:02 - WebIOPi - DEBUG - Device instance add
2017-11-15 15:25:02 - WebIOPi - DEBUG - Mapping NativeGPIO.digitalCount to REST GET /GPIO/count
2017-11-15 15:25:02 - WebIOPi - DEBUG - Mapping NativeGPIO.digitalRead to REST GET /GPIO/%(channel)d/value
2017-11-15 15:25:02 - WebIOPi - DEBUG - Mapping NativeGPIO.digitalWrite to REST POST /GPIO/%(channel)d/value/%(value)d
2017-11-15 15:25:02 - WebIOPi - DEBUG - Mapping NativeGPIO.getFunctionString to REST GET /GPIO/%(channel)d/function
2017-11-15 15:25:02 - WebIOPi - DEBUG - Mapping NativeGPIO.portRead to REST GET /GPIO//integer
2017-11-15 15:25:02 - WebIOPi - DEBUG - Mapping NativeGPIO.portWrite to REST POST /GPIO/
/integer/%(value)d
2017-11-15 15:25:02 - WebIOPi - DEBUG - Mapping NativeGPIO.setFunctionString to REST POST /GPIO/%(channel)d/function/%(value)s
2017-11-15 15:25:02 - WebIOPi - DEBUG - Mapping NativeGPIO.wildcard to REST GET /GPIO/*
2017-11-15 15:25:02 - WebIOPi - INFO - GPIO - Native mapped to REST API /GPIO
2017-11-15 15:25:02 - WebIOPi - INFO - Loading configuration from ./config
2017-11-15 15:25:02 - WebIOPi - INFO - Access protected using /etc/webiopi/passwd
2017-11-15 15:25:02 - WebIOPi - INFO - HTTP Server binded on http://10.0.0.111:8000/
2017-11-15 15:25:02 - WebIOPi - DEBUG - deviceDetector
2017-11-15 15:25:02 - WebIOPi - DEBUG - detectOneWireDevices
2017-11-15 15:25:02 - WebIOPi - DEBUG - 00-ba0000000000
2017-11-15 15:25:02 - WebIOPi - DEBUG - 00-7a0000000000
2017-11-15 15:25:02 - WebIOPi - DEBUG -

Install log:
Copying default config file…
‘python/config’ -> '/etc/webiopi/config’
Copying default passwd file…
‘python/passwd’ -> '/etc/webiopi/passwd’
Installing startup script…
Installing webiopi command…
Installing webiopi-passwd command…

WebIOPi successfully installed

  • To start WebIOPi foreground : sudo webiopi [-h] [-c config] [-l log] [-s script] [-d] [port]

  • To start WebIOPi background : sudo /etc/init.d/webiopi start

  • To start WebIOPi at boot : sudo update-rc.d webiopi defaults

  • Look in /tmp/webiopi/examples for Python library usage examples

(98%)
Wed Nov 15 14:02:37 CET 2017 Configuring os and agent
(100%)
Wed Nov 15 14:02:44 CET 2017 Install finished
Your system will reboot!


#2

Hi @tom.makula, welcome to the Cayenne Community. Could you share your output from:

service myDevices status and service webiopi status so I can verify things are running OK? If they are, the next thing I’d check is if port 8181 is open on your network.

The Cayenne Pi agent software requires port 8181 to be open to communicate with our server. If it’s not able to do that, that is one reason it may appear on your dashboard.

You can use telnet to check if the port is open. This is not installed by default on a Raspbian install anymore – you can install it using sudo apt-get install telnet

If the port is open you will see the following (your IP addresses may or may not be the same as mine):

pi@raspberrypi:~ $ telnet cloud.mydevices.com 8181
Trying 54.165.135.17...
Connected to cloud.mydevices.com.
Escape character is '^]'.
Connection closed by foreign host.

If the port is closed you will see the following (your IP addresses may or may not be the same as mine):

pi@raspberrypi:~ $ telnet cloud.mydevices.com 8181
Trying 52.6.151.66...
Trying 54.165.135.17...
telnet: Unable to connect to remote host: Connection timed out

#3

Hi, thaks for reply,
I tried both, it seem to be something wrong with myDevice service:

root@malina:/var# service myDevices status

  • myDevices.service - myDevices service
    Loaded: loaded (/etc/systemd/system/myDevices.service; enabled)
    Active: failed (Result: start-limit) since Wed 2017-11-15 14:03:21 CET; 6h ago
    Process: 608 ExecStart=/usr/bin/python3 -m myDevices -P /var/run/myDevices.pid (code=exited, status=1/FAILURE)
    Main PID: 608 (code=exited, status=1/FAILURE)

Nov 15 14:03:21 malina systemd[1]: Unit myDevices.service entered failed state.
Nov 15 14:03:21 malina systemd[1]: myDevices.service holdoff time over, scheduling restart.
Nov 15 14:03:21 malina systemd[1]: Stopping myDevices service…
Nov 15 14:03:21 malina systemd[1]: Starting myDevices service…
Nov 15 14:03:21 malina systemd[1]: myDevices.service start request repeated too quickly, refusing to start.
Nov 15 14:03:21 malina systemd[1]: Failed to start myDevices service.
Nov 15 14:03:21 malina systemd[1]: Unit myDevices.service entered failed state.

Comunication looks fine:

root@malina:/var#
root@malina:/var#
root@malina:/var# telnet cloud.mydevices.com 8181
Trying 34.199.178.126…
Connected to cloud.mydevices.com.
Escape character is ‘^]’.

^C
^]
telnet> quit
Connection closed.


#4

Hi, anybody has some suggestions? How to debug it? What can be wrong?
thank you


#5

What happens when you run this in a terminal window?

/usr/bin/python3 -m myDevices -P /var/run/myDevices.pid