Cannot create trigger


#1

What dashboard are you using? (Web, iOS, Android)
Web


What OS? (Jessie, Wheezy)
Jessie


What Model Pi?
B


Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!
I have temperature sensor set up. When i go to “create new trigger” I can set name of trigger, type of notification but i cannot set device in “if” section. I tried drag and drop from left hand side menu. While dragging item only name textbox changes its colour to grey.
Im using chrome Version 52.0.2743.116 (64-bit) on MacOs El Capitan.


#2

Are you always stuck under the setup notification? Or are you clicking on it for some reason in particular? Cancel your trigger, start a new one, and you should be able to drop your device (in your case the pi) in first (in the “if”), then select your sensor from the drop down.


#3

@karol.sendyka

Can I ask if you’re trying to drag the top-level ‘Raspberry Pi’ item into the ‘if’ box, or one of the items beneath it? If you drag the top-level ‘Raspberry Pi’, it should pop into the if box and then provide a list of everything under that device that can be used for sensors.


#4

@usmcwarmachine @rsiegel It works! Thank you. I was trying to use particular sensor instead of raspberry pi device. By the way: its not obvious what I should put there and I’m able to drag and drop both items. Maybe its worth considering UX improvement here.


#5

Yeah playing with it a bit I agree, I’m going to see if we already have something on the UX here internally and add it if not.


#6

Right on!