Cannot install for Python 3.2.3 : missing development headers


#1

What dashboard are you using? (Web, iOS, Android)
Web


What OS? (Jessie, Wheezy)
I believe it’s Wheezy. All I know is it’s Raspbian.


What Model Pi?
Raspberry Pi 2 Model B


Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

I am trying to setup a new Raspberry Pi device and it continues to tell me : “Cannot install for Python 3.2.3 : missing development headers\n”

Any help is greatly appreciated. I can provide more details but the answers I’ve found on this forum so far haven’t worked.


#2

Hi @ttp0001,

Welcome to the Cayenne community!

I would clean your current SD card and install the latest version of Jessie from Raspberry Pi.

Wheezy isn’t officially support anymore, since Raspberry Pi doesn’t support Wheezy either.

Keep us updated.

-B


#3

Also stay away from Jessie Lite.

There are some workarounds to get it working, but unless @bestes can confirm, Jessie Lite is still not supported.

Update: SWEET! I just saw the release notes for today. Jessie Lite is supported. Great work guys!!!


#4

You beat me to it :slight_smile: Yep, Jessie Lite now supported.

-B


#5

Unfortunately Jessie is the only version you can install Cayenne on at the moment. Wheezy is no longer supported by Raspberry Pi so MyDevices won’t be testing updates for it any more.

haha must have had a cached version up…there a few replies here now :grin: