Can't add channel in a sensor/actuator on Raspberry Pi model B


#1

Hi,

I installed Cayenne on Raspberry Pi via the script (Not mobile app). The device and its readings are now being shown in the Cayenne dashboard. However, when I was trying to add an actuator (Light switch), the drop down box for ‘Channel’ is shown disabled so I couldn’t select the GPIO number on which LED is connected. It therefore didn’t allow to add the device/widget as well.
Tried that with other device/widgets and the same issue persists.

Also, when I click on the GPIO tab in main dashboard, it didn’t show anything. I tried rebooting Pi twice as well.

OS running on Pi is Raspbian Jessie.

After some playing I found that the Raspi configuration needed to be changed. ‘Enable Remote IO’ needed to be enabled in configuration.

Documentation on Cayenne says no configuration changes are needed as the installation does it automatically. I think there is either a bug in the installation script or the documentation needs change. Or maybe I missed to do something.

Thanks,


#2

Hi @gopal.amlekar,

Thank you so much for letting us know about this! It’s the users like you that help us make Cayenne better :slight_smile:

So just to clarify, the ‘Enable Remote IO’ fixed the problem you were experiencing?

-B


#3

Yes that is correct. Enabling Remote IO fixed it.

Thanks,
Gopal


#4

I am using Raspberry Pi 3 Model B, using Jessie and have same problem with @gopal.amlekar ‘Channel’ is shown disabled when I trying add distance sensor.

I have enable Remote GPIO (Raspberry Pi Configuration, Interfaces, Remote GPIO, enabled). Is there anything I should do to add the sensor?

I have Raspberry Pi 2 also but have same problem when trying add sensor. I have add temperature sensor to the Raspberries and it’s working well, but why I cannot add distance sensor?

(Note: I have add the distance sensor with Arduino Uno and it’s working with some customized code)


#5

I just had some play with it and here are the findings.
An analog sensor needs to be connected to the Pi through an ADC, not directly as there is no analog input pin. So you need to connect and configure and ADC first from ‘extensions’. After that if you add any analog sensor, say the distance sensor in your case, then select the connectivity as that ADC and select the channel to which you have connected the analog sensor.


#6

@willy What distance sensore do you use? Be careful, the most common used HC-SR04. For the trigger signal you have to use an voltage divider. So, the trigger works wit 5 volt logic, but the pi can only handle 3,3 volt. So maybe you have to check this first to not break the pi.


#7

@gopal.amlekar thanks for the tips, I have done it with arduino and have looked back again, yes it’s true that I’m added the sensor with generic type, I think for raspberry it should added with the same method (Generic)

@tooony yes, I have HC-SR04 and one other which is water resistant, I have try both on arudino and seems like it is identical, they both work on arduino. I will try to read the tips to implement that on pi. thanks.


#8

can you get it working? :slight_smile:


#9

@tooony I haven’ tried the pi again, right now I want to play with NodeMCU first. I let you know if I have tried with pi. thanks for your concern.

Anyway, have you tried distance sensor + pi + cayenne and is it work? Because in your python code, I don’t see it has output to cayenne.
I hope someday cayenne has built in feature for the distance sensors.