Cant login in the iOS app


#1

Hello, I tested it few times: I am not able to login into the cayenne iPhone app with my account. It tells me to enter a valid email. I changed my password once, that was not a solution.
Login via the web-app worked well.


#2

Hi @msallat,

Is this the app you downloaded? I only ask because we have a legacy ‘myDevices’ app that was created some time ago, I want to be sure you downloaded the correct app.

-B


#3

yes, I used the correct cayenne app, not the old myDevices app. Any Suggestions?


#4

Hmmm, this is weird. @twong any suggestions here?

-B


#5

Hi @msallat,

I see what’s up here, it’s a bug in our mobile apps where they don’t think email addresses in the format:

name@aaaa.b-c.com

are OK. They are valid (as you well know, that’s your email address!) so it’s our bug, apologies.

We’re going to push out a fix soon for both iOS and Android. If you’d like to use the iOS app in the meantime, PM me with an alternate email address, and I can change your account to it so you can login on iOS. I can change it back when we push the fix, too.


#6

I know this is an old post but I am having the same problems… are you able to do the fix for me also?


#7

Hi @mathewbrooks86, welcome to the Cayenne Community, and no worries about bumping the old thread.

This issue should be fixed in the current iOS build (2.1.0), so please check that you have the latest from the App Store if you’re on iOS. It looks like it remains an issue on Android.

If you’re planning to use Android, and have some alternate email address that doesn’t share that format, one option would be to make an account there, and I’d be happy to have a someone on our end change your email address back to the preferred one with the name@aaaa.b-c.com format as soon as it’s fixed on Android.


#8

Hi @rsiegel . I currently have a gmail account which previously work well, no problems. When I tried to load software onto pi, it will not work. I am currently running latest version of the app.

Are the user name, password and ssh that of the pi or my cayenne account? And is the ssh set to 22 as standard or am I confusing it with something else…

Forgot to mention I am running the app on iOS

I really can’t remember how I did it the first time :flushed:


#9

Ah I see.

Yeah, it’s asking for the username / password of an account on the Pi (by default, pi / raspberry) , and the default SSH port is 22, unless you’ve changed it.

Please note that in more recent versions of Raspbian, the SSH is disabled by default, so you might want to check on the Pi itself if the SSH interface is enabled (step 2 in this documentation): https://www.raspberrypi.org/documentation/remote-access/ssh/

If it’s still not behaving for you, you can do a manual install from the web dashboard by logging in, adding a new Pi, and following the on-screen instructions until you get to ‘Option 2’ where it gives you two commands to run on the Pi to install the Cayenne agent. Once the agent is installed and the Pi is connected to Cayenne, it will show up in the iOS app, even if you did not install it from there.


#10

Hi, just to update,

I used the code via SSH to install onto the pi and now all is working again

Thanks again

Mat