Cayenne consumms a lot of memory


#1

Hello there,

Monitoring my Pi with my own system, I’m really surprised of the memory used by Cayenne.
Here is the weekly graph:
I had installed Cayenne the 02-19, you can see the memory usage variation after that… Very surprising !


#2

We’re going to look into the memory usage. We’ve had people bringing this up recently. I’ll update this thread with some information as to why the memory usage is high and if we will be able to decrease it.

Thanks for bringing this up!

-B


#3

I think this should be fixed now for RAM. Let us know otherwise! Thanks for you patience. I’m moving this topic to ‘Helped’.

-B


#4

All right, I’ll test the new release in a few days.
Thanx !


#5

Cayenne data aquisition/graphs seem to consume RAM on my Pi3 and triggering a reboot when RAM reaches a certain level (80% for example) does not actually work. I am forced to manually reboot when a trigger notification emails me (this works well)


#6

Hi @deepdreamtechnologie, welcome to the Cayenne Community.

This is the #1 bug on our radar and should be resolved in the near future, my apologies for the RAM issues you’ve been seeing with the Pi agent. Another option that should work is scheduling a daily reboot of the Pi at a convenient time (this should work), or connecting the Pi via our MQTT API rather than through the ‘Raspberry Pi’ option in the Cayenne UI.

I’ll be updating the Community as soon as we have a resolution on this issue in the form of a Pi agent update.