Cayenne Dashboard keep Crashing and not responding after few seconds from Loggin in


Ok, many thanks to @helpdesk I think we at least see what’s going on here (I suspect this also covers many of the others in the thread)

The way our website is currently architected, each Pi/Arduino device creates a websocket connection. In this particular account, there were probably ~30 Pis, which equals 30 websocket connections, which equals :fire::computer: (at least that’s what happened to mine – runaway CPU consumption :hushed:)

We’ll be replacing this architecture soon with one that only uses 1 websocket per browsing session, (the same that we use for MQTT and LoRa devices). In the meantime, there are a few potential workarounds:

  1. As mentioned above, this issue does not occur with MQTT devices, and both Pis and Arduinos can be connected via MQTT. So one option would be to remove ‘traditional’ Raspberry Pi and Arduino entries and re-add them to the dashboard as MQTT devices.

  2. Until this is fixed, another option is to split your devices between multiple accounts. I generally run with 8-10 devices on my account without much slowdown – I suspect this will come down to system specs more than anything else.

If @helpdesk or anyone else in this thread needs help with removing devices from your account so you can re-add them via one of these methods, but can’t because of the slowdown, please let me know and I can assist, and thank you for helping us find this architectural issue.

Shceduler troubleshooting

tagging @techsupport, @adam to see if this meshes with what you might have seen in the past (i.e. did you have a lot of devices on your account when you saw slowness/crashing?)


No, I only ever have about 5 devices online at any time, most of them are arduino. I haven’t really noticed and slow downs lately, might have been a fix pushed in Firefox.


I have been experiencing the same issue recently, and I only have 2 Pi’s on cayenne. I also tried removing one of them, leaving one single Pi on the dashboard. Unfortunatelly, the dashboard still ‘crashed’, meaning that the page quit responding.
I tried to run the dashboard from a windows 7, windows 10, and android device. I also tried several different, independant networks.


Hi @pythonprogram2010, and welcome to the Cayenne Community.

I’m sorry to hear you’ve run into this issue. Do you mind sharing your account credentials via Private Message on the forum so I can investigate and reproduce on my end? It sounds like you’ve run into something potentially new and different if you only have a couple devices on your account and can’t load the dashboard on so many different platforms. It’s probably something funny in the data on your account that is choking our system somehow, that’s what I’d like to look for.


Thanks for the account credentials. Weirdly I’m not seeing this on my end – I’m running it on Mac Chrome, Safari, Win10 Chrome, Win10 Edge, and the Cayenne Android app all at once.

In each case, there is some CPU usage to maintain the dashboard, but I’m not seeing the browser become unresponsive or display any error message.

Is it possible you are running any sort of browser extension/javascript blocker that could be interfering with our dashboard operation? Seems unlikely considering the number of devices you’ve seen this on, but worth checking. Also worth clearing your browser cookies/cache before trying again as well – I should mention I’m seeing two Raspberry Pis on your account, so maybe something went wrong when you were attempting to delete the one you mentioned and got the software in a weird state?


Thank you for taking the time to look into this.
I don’t have any blockers/anything non-standard associated with my browser. I will clear the cookies as you mentioned and see what happens there.
I did at one point have an issue with linking one of the Pi’s that are currently on the network. I had to remove the device from Cayenne twice - that could very well have caused a problem associated with cookies on my end.

Thanks again for the assistance. The Cayenne leadership/technical support team is amazing!