CPU at 100% after isnstalling Cayenne on pi zero W


#1

Please Help
CPU at 100% after isnstalling Cayenne on pi zero W


#2

Can you run top and copy the output of the program here, or make a screenshot. I want to see which service makes your CPU at 100 %.


#3

If it turns out to be the Cayenne Pi Agent which is consuming the CPU (this would usually show up in top as python3) there are a few options you may be interested in for a lighter client:

Connecting your Pi as an MQTT device rather than using the Raspberry Pi agent software will be lighter in CPU use, as the MQTT client is only handling publishing and subscribing to MQTT topics rather than any other logic. The current Pi agent it collecting some information like CPU/RAM/Pi Process information every few seconds in order to create some widgets to demo the Cayenne dashboard which uses CPU time, so if you don’t care about this information this is a good (and more flexible) option.

Alternatively, we have a Beta version of our new Pi Agent that you can update your currently installed agent to – which should have many performance changes and improvements. Please be aware that this is Beta software though - only run it if you want to see the cutting edge but are prepared to deal with the occasional bug/issue until it hits official release. If you want to update to this agent:

First get the test agent install script:
wget http://updates.mydevices.com/raspberry/rpi_testing.sh

If updating an existing install run:
sudo bash rpi_testing.sh -update

If this is a new install get the invite code from adding a new Raspberry Pi via the Cayenne Dashboard. The invite code is part of the install file name listed in the Terminal/SSH instructions: rpi_[invitecode].sh.
Run the rpi_testing.sh script with this invite code:
sudo bash rpi_testing.sh -code [invite code]


Raspberry Pi Zero W