Dashboard arrangement not saving position


#1
  • Device & model you are using (Ex: Pi 2 Model B or Arduino Uno with W5100 ethernet shield)
    Arduino Mega via ESP8266

  • What dashboard are you using? (Web, iOS, Android)
    Web

  • Please describe the bug / issue as detailed as possible. Attaching the code and any relevant screenshots would be very helpful!

Voltage graph in pic below is off to the right. No matter how many times I move it left so its next to the battery voltage value display, it moves back over to the left when you log out/in or refresh the page. Going from one device to another on the navigation tree doesn’t do it, just on reloads or logins. Started about a week ago.


#2

Hello Sir,

What about to move it and wait a little bit, then log out/ log in ?


#3

Tried that. This has been going on for a week or two now. No matter what I have tried it always moves back to the right upon login.


#4

I tested for myself now. I don’t have problems with re position…


#5

What about if you choose not to be a Line Graph widget, but a value widget. Are you able to move?


#6

I changed the widget type and it still does the same thing. None of my other projects have any issues moving widgets around and staying put… just this one. Very weird


#7

Do you see the same behavior if you try a different browser?


#8

yes. So with Chrome on my Win7 and Win10 computers it does it when I log out or refresh the page. I just tried Firefox on my Win7 computer and it does it just when I click to another device & back in addition to refreshing/logging out. So it doesn’t stay at all with Firefox. Let me know if you want me to try anything else.

I haven’t tried deleting it and re-adding it yet FYI


#9

Thanks. I can reproduce something similar, not exactly what you see but ultimately a problem where widgets are not retaining their position when I refresh the browser. I think this will be good enough for me to log a bug with our development team, and use yours as another example for them to investigate.