ESP-12S & Arduino Mega - only one of each can work


#1

Hello Everyone,

I’m struggling with connecting my ESP-12S & Arduino Mega to Cayenne. Being complete beginner in Arduino I made a progress with many youtube movies and spending days on forums. It brought me to the point where ESP can connect to my WiFi and I’m able to connect Arduino via USB connection to Cayenne. What I cannot do is to connect Arduino to Cayenne via ESP.

I’m using this wiring: https://cdn.instructables.com/F3W/ON46/IYKG2WG9/F3WON46IYKG2WG9.MEDIUM.jpg?width=614

When I have connection between RST and GROUND on Arduino (green wire on diagram) I’m able to connect to WiFi with ESP but not being able to upload Cayenne code for Arduino Mega with WiFi Shield. ArduinoIDE is showing:

avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
An error occurred while uploading the sketch

When I take out this connection, I’m able to upload the code but in Serial Monitor see info that “[14] WiFi shield not present”. Managed with success to connect Arduino via USB to Cayenne but this WiFi connection irritates me.

Is someone seeing where I’m making mistakes?


#2

(I don’t have a ESP-12) [quote=“mateuszwesierski, post:1, topic:2777”]
When I take out this connection, I’m able to upload the code but in Serial Monitor see info that “[14] WiFi shield not present”. Managed with success to connect Arduino via USB to Cayenne but this WiFi connection irritates me.
[/quote]
Did you tried to reconnect the shield after uploading the code?


#3

Thanks Neoxelox for respond!

I just wanted to make an update. Almost all yesterday I’ve spend on forums and testing different solutions. I’ve understood very important thing - Cayenne & WiFi Shield code is not compatible with ESP8266 :unamused: Lost some nerve on that but it was some step forward. Now I’m using the code found WifiShield with arduino uno compiling error

After uploading ESP dedicated code I’m getting this error read in 9600 baud:
[519] Connecting to name of my network
[1530] Failed to disable Echo

Read that it could be connected with old AT firmware or power supply. Newest 1.5 firmware has been uploaded, power supply replaced to stable one used for external HDD connection and 5V dropped down to 3.3V via YwRobot module. No positive results. Even worst due to the fact that ESP is not reacting on AT commands. Just showing in 74880 baud:

 ets Jan  8 2013,rst cause:2, boot mode:(3,6)

load 0x40100000, len 1856, room 16 
tail 0
chksum 0x63
load 0x3ffe8000, len 776, room 8 
tail 0
chksum 0x02
load 0x3ffe8310, len 552, room 8 
tail 0
chksum 0x79
csum 0x79

2nd boot version : 1.5
  SPI Speed      : 40MHz
  SPI Mode       : DIO
  SPI Flash Size & Map: 4Mbit(256KB+256KB)
jump to run user1 @ 1000

#4

Looks like you are still in boot mode.

You need to remove the shirt between D0 and ground, leave D15 to ground, and then reset or power cycle.

Cheer,

Craig