[Fixed] Problem with adding devices


#1
  • Android device info: Samsung Galaxy S4 (i9500)

  • Raspberry Pi device info (Pi B w/ Raspbian Jessie version 02/26 build)

Can’t add existing or new Pi to android app.

Scan Network finds them, select the device, and insert my SSH details.

When I select a device already running Cayenne says "Please select a device to setup"
Selecting a device not running Cayenne says “Please check SSH configuration”

What am I doing wrong?


#2

Try pressing the refresh icon in top right corner when searching for devices?


#3

I’ve force closed the app, and restarted everything. No luck…


#4

@bestes has this build gotten around the need to use the default password.

Previously when I saw a SSH error it was because I had changed the password.

Ian


#5

Did you change password from default pi / raspberry? It shouldn’t matter since we allow you to put your SSH password, but there may be bug we never encountered with this. Might be able to confirm if you put pi / raspberry as the password again.


#6

@Ian So, I should try a fresh install of Jessie and not change the SSH username/password?

@bestes I did change it yes, and on both devices.


#7

Yeah I think that’s the way to go at this point. Thanks @Ian for the heads up.


#8

This is a note from Brent for the 0.25a build.

• The Alpha version still currently requires the SSH password to be the default “raspberry” if you are installing a new agent. You can change the password after the agent is installed. If you are installing a new Android app version and using your existing account, you should not have to take any action.

I don’t know if this problem has been resolved yet…

@derikj
You might try just changing the password back to the default before burning a new card

Ian


#9

@Ian Changing the password didn’t help. I’ll rebuild and try again.

Thanks!


#10

Sounds good, keep us updated.


#11

Nope… Still the same… Fresh Jessie install. No changes.


#12

@derikj

Derik,
Sorry you are still having troubles, if it makes you feel any better you got farther than I did. I’m having discovery problems with fresh starts and new accounts.

I think the problem I mentioned earlier has been resolved because in the .22, .23, .25 versions there was not a place to enter ssh username/password like you have.

I’m just taking a guess now, but I’m wondering if your SSH server is enabled. The default is suposed to be enabled, but you might check.

Well I’m going to take another look at what I have going on, I’ll try getting into one of my established accounts next.

-Ian


#13

I would verify from your Android phone that you can SSH into the Pi device using the credentials that you are entering into Cayenne. This would verify that you can connect to the Pi via SSH over the wireless. That would at least verify that Cayenne should be succeeding. You can use an app such as ConnectBot for an ssh client from your phone.


#14

SSH works via ConnectBot, as well as the Tasker SSH plugin.


#15

Working now after latest update!


#16

Great to hear!


#17

This topic is resolved.


#18

#19