GPIO dashboard not giving options for input/output or high/low


Thank you for taking the time to submit your bug/issue! Please use the points below as a guide when submitting.

  • Raspberry Pi 3

  • Dashboard: Web and Android (same issue on both)

  • When I go to the GPIO dashboard for my pi the area where it should let you select input/output is blank and the area to select high/low is also a blank white square. When I try to plug in an LED and enable it through digital out it does not work. It seems something is not enabled or there is a bug. Any suggestions?

Snippet of what my GPIO dashboard looks like.


Hi @rjbeckwith55 and welcome to the Cayenne Community.

This looks like the you’re running the 4.9 Linux kernel, while currently webiopi (a component of Cayenne) only supports the 4.4 that ships with stock Raspbian Jessie. You can check your kernel version with the command uname -a on your Pi.

If you have no specific need for the 4.9 kernel on your Pi, you can downgrade to 4.4 by running this command (it will require a reboot after it runs)

sudo rpi-update 52241088c1da59a359110d39c1875cda56496764

After you’re running 4.4 again the problems you’ve described should automatically go away. If you do need the 4.9 kernel specifically, you can still use Cayenne by running an MQTT Client on your Pi using our Python MQTT Library instead of the Raspberry Pi agent that you’re currently using. Certainly feel free to ask me for help if you want to go down this road.

Regardless, we have a fix for the 4.9 compatibility issues that is already developed and currently being tested with our QA team. As soon as it is released, your current Pi agent will be automatically updated and then you can run whichever kernel version you prefer. We’ll make an announcement of its release in the Announcements section of our Cayenne Community forum at that time.

Please let me know if you have any questions.


Hi @rjbeckwith55,

I am new here too.
However after so many trys I have it working with my Pi Zero W running Raspbian Jessie with PIXEL

I turn on these Confirurations prior install Cayenne ( make sure to change PI password for SSH)


Moving this to Resolved per the kernel downgrade I outlined above, but certainly if there is any issue with it feel free to bump up the thread or create a new one.



I just wanted to bump this thread to note that we’ve now updated our Pi agent to support the 4.9 kernel (it still supports 4.4 as well). The update was automatic in the background so there is nothing you need to do on your end. Feel free to use rpi-update to move forward to the 4.9 kernel at this point if you’d like!