How to add wifi to Raspberry PI?


#1

How to i install wifi usb adapter ? I cant connect raspberry to inernet with wire.


#2

There are many wifi adapters that will work with Pi. Plug it into USB ports, then what would probably be easiest is if you log into the GUI desktop of pi and connect the Pi to the Wifi network by clicking the internet icon in the top right of the desktop screen.

-B


#3

I have only connection over ssh.


#4

I have follow this tutorial before and it seem to work.


#5

I have RT5370. With this problems:


#6

hi seston, I use RT5370s.

There are a number of ways to get wifi working… plug the device in and run

sudo lsusb

is the device listed?

are you using the latest full version of raspbian jessie?

If yes there is a config tool in X which really makes connecting to a WAP simple.


#7

I see this with lsusb. Latest Raspbian Jessie. I connect to Raspberry over ssh. If i connect monitor and make connection in X after rebooting and if raspberry started without X this connection working ? I have Raspberry 1 model B for Cayenne. I do not want tow cat5 130 meters :slight_smile:


#8

Yes that will work. I do this myself a lot as it makes setup quicker.

The Gui setup is in the top right corner of X click the network icon and select your WAP. Enter your password etc

Then run the raspi-config and disable X the settings will stick. All it does is build the wpa-supplicant files for you.

Should work perfectly. Just remember though that you will have a dhcp ip and this will change your ip from time to time so if your router supports it try and reserve the ip.

Ip won’t matter to cayenne though.


#9

I use in IPhone software Fing. This find all my lan addresses :slight_smile: I try after work .


#10

Hey seston, did you get this going OK in the end? Just curious :slight_smile:

I checked out Fing as well, awesome btw, thanks for that tip. Much more handy than ipscan.exe


#11

I install wicd-curse, or something. This is working without x. Connecting automatically iif pi lost connection.


#12

Today i try again. I do not have time. :frowning: