IBeacon not connect using MQTT


#1

I’m using an IBeacon gateway, where it has fields to rearrange the MQTT configuration, so I created a simple device on the Cayenne in which it gives me the values ​​to store on my device. I did everything right, but he even gets the data, but does not create the Widgets.

here the settings of the Cayenne MQTT

here the IBeacon fields

I think there’s some problem with Cayenne.


#2

try topic v1/username/things/clientID/data/channel + payload
Read more about this https://mydevices.com/cayenne/docs/cayenne-mqtt-api/#cayenne-mqtt-api-manually-publishing-subscribing


#3

I tried to send the data through MQTT.fx according to the documentation, but it still was not.
For example:
v1/d8fe64e0-5a9f-11e7-80f0-a334be42512c/things/640d2260-903c-11e8-9075-e9c6dcfa3ddd/data/1/temperature

v1/d8fe64e0-5a9f-11e7-80f0-a334be42512c/things/640d2260-903c-11e8-9075-e9c6dcfa3ddd/data/1+temperature

v1/d8fe64e0-5a9f-11e7-80f0-a334be42512c/things/640d2260-903c-11e8-9075-e9c6dcfa3ddd/data/1:temperature

This is the data that the gateway sends:

[{"timestamp":"20180726T20:26:07Z","type":"iBeacon","mac":"AC233F25252A","bleName":"","ibeaconUuid":"E2C56DB5DFFB48D2B060D0F5A71096E0","ibeaconMajor":0,"ibeaconMinor":0,"rssi":-52,"ibeaconTxPower":-59,"battery":0},{"timestamp":"20180726T20:26:06Z","type":"S1","mac":"AC233FA03DB6","bleName":"","rssi":-69,"battery":100,"temperature":15.91,"humidity":57.05},{"timestamp":"20180726T20:26:07Z","type":"S1","mac":"AC233FA03E16","bleName":"","rssi":-50,"battery":100,"temperature":21.34,"humidity":66.96}]

I think it will not be possible for the Cayenne, I’ll need to find a dashboard where I can manipulate the incoming data.


#4

v1/username/things/clientid/data/channeltemp,c=20


#5

I tried but it did not work :confused:


#6

tagging for this @eptak


#7

@robsonmartinazzo

You almost got it right, first of all there are two ways of sending data.

Option 1:
Topic should be: v1/d8fe64e0-5a9f-11e7-80f0-a334be42512c/things/640d2260-903c-11e8-9075-e9c6dcfa3ddd/data/1

Now the payload format:
temp,c=23

Option 2:
Topic v1/d8fe64e0-5a9f-11e7-80f0-a334be42512c/things/640d2260-903c-11e8-9075-e9c6dcfa3ddd/data/json

Payload in JSON format:
[ { "type": "temp", "unit": "c", "value": "23.0", "channel": 2 } ]

Hope this help, let us know.


#8

@asanchezdelc

In the last package sent it shows that it has arrived, but it is not creating the dashboards. Is it necessary for the json package to send the channel? Because the data my gateway sends are fixed, I can not put another channel-type property.


#9

Oh I see what you mean now. We can’t parse the IBeacon payload, you have to conform to the MQTT API by following the topic and payload format.