Installation does not complete for Raspberry Pi


#1

What dashboard are you using? (Web, iOS, Android)


What OS? (Jessie, Wheezy)

Raspbian


What Model Pi?

3


Please describe the bug / issue. Attaching any relevant screenshots would be very helpful!

The installation does not complete. It hangs attempting to reboot the Pi. Manually rebooting the Pi does not help.


#2

Hi @thomas.engelmann,

I want to be sure the topic of this bug. Is it about the Raspberry Pi Remote Access feature from the Cayenne dashboard or just trouble adding a new Pi to your Cayenne account? It sounds like the latter but your subject line threw me off.

If it is an issue with adding a new Pi, can you let me know if you’re using the Mobile apps or the ‘Option 2’ from the web dashboard (pasting a few lines into a command prompt).

Also could you let me know the output of the command cat /etc/os-release ?


#3

Hi,

The problem may be due to my having deleted a previous Raspberry Pi from Cayenne since it is no longer functional. I want to replace it with my new Pi. So I deleted the old one and started over with the new Pi. Everything seemed to be working as expected until it came to the last step, at which Cayenne wants to re-boot my Pi. The message says this may take ten minutes to complete but it appears to hang at this step. I tried re-booting my Pi myself but to no avail. I am working through a public Wi-Fi at Bitterroot College (University of Montana) instead of the secure Wi-Fi. Could this be the source of my problem. When I established by old Pi with Cayenne everything went as expected but I was using a secure Wi-Fi. I can connect my Pi directly with an Ethernet cable if you think this would help.

Here is the output of cat /etc/os-release:

PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL=“http://www.raspbian.org/RaspbianBugs

Thanks for all your help and hope to hear from you soon,

Tom Engelmann


#4

Hi again.

From what you’ve described, it sounds like the Pi agent likely installed OK and just isn’t connecting to our Cloud Server after the Pi reboot.

It sounds like you may be on to something with regard to the public wifi – the Cayenne Raspberry Pi agent needs port 8181 to be open in order to connect to our cloud server. If you have access, even temporarily, to put the Pi on a network where you can confirm that is open, that would be a good test. This post has great troubleshooting steps on getting the Pi to connect to our cloud server that you can walk through as well. It also has steps to confirm if your network has port 8181 open.

It is of course possible that our install failed for some reason. The reason I asked (and still want to know) whether you installed via the mobile app or via our web dashboard, is because in the former case, there is not much error messaging displayed in the mobile app. It sounds like you probably installed via mobile?

If you did install via mobile, and the above troubleshooting steps didn’t resolve the issue, the next best move is to install via command line from the web dashboard.

To do that, first run these commands to uninstall anything which may have been left behind from a failed installation:

sudo /etc/myDevices/uninstall/./uninstall.sh

then

sudo /etc/webiopi/uninstall/./uninstall.sh

Next, log into your account and do Add New > Device/Widget > Single Board Computers > Raspberry Pi and scroll down to Option 2. Install from those commands on the Pi itself, rather than from the mobile app. It does the exact same thing as the mobile app, but because you’re at the command line, you’ll be able to see any relevant errors displayed if and when the install process fails again, and be able to share them here. Here is hoping that it was just your network and you never have to go this far! :slight_smile:


#5

And are you having any trouble with our Remote Access feature? The title of this thread keeps throwing me off! Please let me know if I’m ignoring some other issue you’re having with Cayenne.