Installation Issues on Raspberry Pi 3


Dear Community
When I install cayenne on my Pi3 it hangs up on the final part Driver installations. Please can anyone advise. Is cayenne compatible with Pi 3 on Jessie.


Hi @swoodhead,

Welcome to the Cayenne community! Can you check out this post? It was created to help with troubleshooting issues during Cayenne installation.

Keep us updated with your progress.




Welcome to the Cayenne Community!

I had a similar problem the other day loading Cayenne onto a RPi 3b.

I had a freshly imaged 8GB SD with Jessie full version 2016-05-27-raspbian-jessie.img.
Set all the localisation and WiFi stuff and ran the Cayenne install via ssh. It hung on the first pass, I rebooted and re-ran the sudo bash -v (every file name is different, so the x’s will be replaced by letters/numbers on your system) command and the installation finished with out trouble.

I think I’ll see if I can reproduce this behavior…

Again, welcome,



Dang it!

@bestes beat me again!

Isn’t it your day off?


Haha. You mean, not everyone drinks their morning coffee and visits the Cayenne forum?


That is exactly what I’m doing, and I have to be at work in 50 minutes.

Good morning Benny!


Thank you Ian My Pi is now online so I guess next step is to find a sensor
to test out the installation on the Pi Simon

Simon Woodhead Sent from my iPhone


Great to hear Simon. Something as simple as a LED and resistor hooked to a gpio can be great fun for an afternoon.

Turn it on.
Turn it off.
Turn it on…

Keep us appraised.



Hi Ian I think I may still have a problem. I can see the dashboard from my
iPhone and iPad, but there is no dashboard on the Pi. Is this correct

Simon Woodhead UK


Do you mean on the Pi you go to the dashboard and nothing comes up? If so the browser on the Pi ironically is not currently supported.


OK thank you,so access to the dashboard is via the app and iPhone. I miss
understood the instructions Regards

Simon Woodhead


You can log in to the dashboard from a computer with Firefox or Chrome, just not with the Pi itself.


Heads up @swoodhead, I’m going to move this topic to the ‘Helped’ category, and out of the ‘Bugs / Issues’ category…helps organize the forum. Hope you don’t mind!