Installing Cayenne - SSH troubles


#1

I am having major problems pushing the software to a RPI3. I am bein asked for a numerical SSH code and have no idea where to find it.

I have installed it in the past but unfortunately it was simply a matter of I kept playing with it until it worked and never did enter a code. This is a huge sticking point and being a total noob I am a tad befuddled.

I have watched the install videos.

Please advise.


#2

Hi @rwadhams, no worries, I’m happy to help.

The app is trying to ask for your SSH Port number so it can log into the Pi to install our Cayenne agent software. This would be 22 on a default Raspbian install. Please note that fresh Raspbian installs disable SSH by default now as a security measure, so you may need to ensure SSH is enabled at all on the Pi. See step 2 in this documentation to for how to do that.

I’m guessing that might be why you ran into trouble here: that SSH was enabled by default in the past, and is disabled by default now.

Let me know if this helps or if you get stuck anywhere else!


#3

Thank you very much that did help. I was missing the port number. Also, FYI, there must have been some sort of update to the RPI3 that switched off SSH. I have no idea why this happened since I enabled it and never shut it off. I was using Cayenne and also Tight VNC with SSH and never had an issue.

Not sure why it happened but just so you know in case you run into it with other users.


#4

Glad to hear that helped sort it out. I do know that they made an update to Raspbian in November 2016 to disable SSH by default on new installs.