MQTT Connection Showing as Offline


#1

I have 2 devices which are both connected to the Cayenne MQTT broker ok, but somehow on the dashboard they are showing as offline. If I follow the raw MQTT data stream everything looks fine, the connection packet looks good and the broker accepts the connection. My ping commands are being acknowledged by the broker, and I’m even seeing data pushed to the broker and it’s responding ok. But still the dashboard shows the devices as offline.

These devices have been working fine before. Is there an issue with MQTT devices at the moment? It almost looks like the dashboard is not talking to the broker?


#2

Yes there is something going on right now. We’re looking into it and I’ll update you as soon as I can.

~Benny


#3

Hello,

I really enjoy your service since it’s helping a lot for IoT projects.
I have a very important project for tomorrow and it has been 2 months that I was working on Cayenne. I am using ESP8266 SparkFun DevBoard. I wanted to run some last tests today, the code is running but I have the same issue : the dashboard is showing “offline”.

Do I have the same problem ? If yes, would you have any update about this ?

Please keep me notified!


#4

Did you make any changes to your project before it went offline? Like take it offline and then brought it back online.

~Benny


#5

No, i didn’t change anything about the code. I just switched off and then now connected back online. Any help would be appreciated!


#6

@sinangokce94 @mulder.roy Can you please try again and let me know how it works?

~Benny


#7

Thank you!
It works. Now it’s online but the problem is that once i press a button, it sends the command but after there is a small circle turning like there was a problem (but there is no problem.) I just have to refresh the page to see the new state of the button. Would you have any proposition for this pseudo-problem?
Thank you!


#8

Yes I am seeing the same thing too.

Updates seem to be coming through but pressing buttons doesn’t work.


#9

I’m having the same issue…Commands going to the MQTT devices are not arriving. Just check two minutes ago.


#10

thanks @sinangokce94 @mulder.roy @jdfletchx7. We are looking into this next. I will update here as soon as I have more info. Thanks for your patience.

~Benny


#11

@mulder.roy @jdfletchx7 Just to clarify, since you are reporting something slightly different than @sinangokce94… The command never reach the actuator? or you are saying the command reaches the actuator but Cayenne does not reflect the change of actuator state (widget keeps spinning until page refresh?)

~B


#12

I’m still encountering a problem with buttons on Cayenne mobile application for iPhone. It seems that there is no connection between the application and my ESP8266 Thing-Dev. (It works on web but there is still something spinning.) Thank you very much for your interest!


#13

Thanks for the update, we’re still looking at this one.

~Benny


#14

Benny,

Don’t know if this info will help or not but I’ll share some specifics of the issue I am seeing. I have four ESP8266 devices connected. Three are configured as Arduino’s and using the the CayenneWiFiClient.h library to connect. They are working as normal. Yesterday I added a new ESP8266 (all four are NodeMCU dev boards) using the MQTTESP8266.h library. The device has no problem connecting but within seconds displays as if offline. This is true on my browser and iPhone app. In the background of my Arduino IDE, it shows as remaining connected. When clicking on a button from the browser, the circle just spins. I have to do a refresh to see the change. One other thing is that I have channel 0 on the dashboard and it is not getting refreshes at all. Here is what the Arduino shows… Thanks much for addressing this. I really like Cayenne,

[17175] Connecting to NETGEAR55
[19678] Connected to WiFi
[19678] IP: 192.168.1.5
[19678] Connecting to mqtt.mydevices.com:1883
[19934] Connected
[20127] Publish: topic 5, channel 65534, value NodeMCU, subkey , key
[20254] Publish: topic 7, channel 65534, value Xtensa32, subkey , key
[20344] Publish: topic 8, channel 65534, value 80000000, subkey , key
[20435] Publish: topic 6, channel 65534, value v1, subkey , key
[31558] Connection ok
[41595] Connection ok
[51633] Connection ok


#15

I have the same issue.The cayenne send 1 to ESP12, widget keeps spinning. When I refresh the page, widget is off but in my device is ON. I can only turn on light never turn off :smiley:
On my phone with android sometimes it’s work well but not always.


#16

@jfb820 @jace-2 Thanks for checking in guys. We have a fix we are testing and will roll out sometime today. Keep you updated!

~Benny


#17

@jace-2 @jfb820 @sinangokce94 @mulder.roy Can you all try your actuators again?

~B


#18

It works! :wink: Great! Thank You very much! the best technical support ever :slight_smile:

P. S. When fix you the slider on android app?


#19

Benny,

I am seeing a partial fix. The iPhone app behavior looks good. When I push a button ON, the corresponding sensor goes HIGH. And when pushed OFF, the sensor goes LOW as it should. However, on the browser, it is not refreshing in both directions. When I push the button ON, the sensor goes HIGH, but… when I push the button OFF, the sensor does not go LOW. I must refresh the page manually to see the change.
Thanks for your support!

I will add that ANY subsequent button pushes after the first one are not updated on the browser (Mac/Sierra/Safari). My Arduino IDE also shows that every button push is generating a Cayenne transaction. Thanks!


#20

Hi I am having the same problems after 2 days my devices went off line so I made a new device to the same ESP8266 and this also worked for about 2 days then I got the spinning dots icon until I refreshed the window , then the next day it went of line!.
Sorted," Client ID " had changed ! Updated ESP8266 programme and all OK.