Not receiving emails or texts from temp triggers


#1

I’ve been searching and have not been able to find an answer to my issue. I set up my Raspberry Pi 3 with Cayenne and added a Temp sensor DS1820B and I see it and view temp changes on my Cayanne phone app and can make triggers. I tried to make a trigger for above 25C and one for below 30C and I am not receiving emails or texts for the triggers. Any thoughts on what I may be doing wrong? it seems very easy but maybe there is a step I missed?

Thanks for your time,


#2

Dear MyDevices Cayenne Team,

I have created simple trigger in Cayenne light switch to send email and message to my mobile when the LED turns on however it doesn’t work. Can you suggest if there is any restrictions or issues.

Thanks
Kabeel


#3

Hi @mervmullin & @kabeelforiot,

I apologize for the issues. There are some known issues with our Triggers system that we’re currently working on. We are actually working on a new Triggers engine that should resolve all these issues. We’ll have a fix soon. Hang in there.

Thanks.
-Jesse


#4

Thank you team

---- Jesse Cruz wrote ----

jcruz

    March 6

Hi @mervmullin & @kabeelforiot,

I apologize for the issues. There are some known issues with our Triggers system that we’re currently working on. We are actually working on a new Triggers engine that should resolve all these issues. We’ll have a fix soon. Hang in there.

Thanks.

-Jesse


#5

@jcruz Hi I presume this issue is still on-going - or do we need to delete and rebuild the triggers?


#6

Any update on this, sometimes it sends the notifications but most of the time it doesn’t.


#7

@chris.2.holland @3d-photo no updates yet, hang in there.


#8

No worries. Thanks for the update.


#9

woks thrillers soon??? 1 month no work and my accuary is in danger


#10

Will the triggers now work when I upgrade to the Agent 2.0? I’ve done a complete reinstall - but I still get asked to upgrade to agent 2.0 and the triggers still dont work :frowning:


#11

yes triggers are working on agent 2.0.

if you have any agent 1.0 device on dashboard it will be asked to update. on your new device do you get the notice?


#12

Bit of a noob - so will describe what I have done.

I formatted the raspberry pi sd card and installed noobs and rasbian. I updated rasbian. connected via my mobile iOS device and installed Cayenne. I set up a couple of sensors and triggers.

On the mobile device I see the raspberry pi as available (with the digital sensors I have set up). I also see a greyed out Raspberry pi as “Pending”.

If I select I can select a number of hardware options but I’m not sure which “hardware” to select - Which is correct ?

If I log on from my pc - I see the same two pi’s and get the pop up “Upgrade to Raspberry PI Legacy agent 2.0 required”.


#13

since the cayenne mobile app is not updated it does not install the agent 2.0. you have to add the pi from the web dashboard.


#14

ok thanks. I’ll use the ssh process. Will that mean the mobile device will no longer connect at all or is it just the install of agent 2.0 is cannot manage?

Have a good weekend


#15

mobile is not update of raspberry agent update. so it wont work with raspberry. arduino and others will work on app.


#16

Good morning! I reset my Pi3 to default and wiped it clean, then I reinstalled the Cayenne agent to make sure the 2.0 client was installed. I then added my 2 Temp (DS18B20A) sensors and i see them on my dashboard and I see their temps rise and fall when testing. I made 2 triggers one for temp above 25C and on fro temp below 30C to send me an email. I do not see the counters increment on the trigger page, I do not get Emails when the temperature fluctuates around these thresholds. I don’t understand if I’m doing something wrong or if they are not working?


#17

can you share screenshot of the triggers?


#18

Here they are. Thanks!


#19

it looks like you have added two trigger for one widget. it wont work this way. delete both and add only one trigger to this widget,


#20

Thanks for your help!

I removed both triggers and when I try to readd them I get “This version of Raspberry Pi Agent has been discontinued. Please upgrade to Raspberry Pi Agent 2.0”. I just just refreshed everything yesterday like I mentioned above. :slight_smile: