PIR Motion detector with ESP8266


Hello ,

I am trying to create PIR Motion detector with ESP8266 I was choosing the Digital Motion Sensor but look like deactivated.

Any advice


You have to select the device that you want you want to assign it. Is this menu deactivated?


yes, the menu is deactivated I can’t choose the device from the menu.


What about the device that you want to add to? Is it active in this moment?


Yes it’s actived my device esp8266


It is very strange issue. Can you try with resetting the dashboard? Turn on/off again ? Something to workaround?


I tried to rest the dashboard and replaced device by another ESP8266 same issue the only things that working the Custom Widgets but Sensors Widget was deactivated.


Maybe @bestes can help here… :frowning:


Hi @zeem411,

Sorry for just now following up…this slipped by me :frowning:

Were you able to find a resolution?



thank you for your concern it’s working now


What was the resolution on this? I have the same exact issue.


@zeem411 what was your resolution? Hoping you can help @jeremy :slight_smile:



Try adding the sensor when your device is online.



Been there, done that. Still doesn’t work.


Can you take a screen shot of your dashboard showing the devices on the left side of the page and your disabled drop down on the right?


I could do that, but it will look exactly the same as the one the previous user posted! I have the very same issue.


Hi @jeremy,
Are you still experiencing this issue?
If so, do you only have ESP8266 devices on your account?
If you add an Arduino device (if you have one available), are you then able to select the Arduino for the sensor?



Yeah, nothing has changed. Very frustrating that this thread never posted a solution to the original problem. I do have other Arduino devices I can try, but the whole point was to use the Sparkfun Thing.


Hi @jeremy,

Hang in there! Use a 2-state button by going to add device process and click ‘custom widget’.


Let me know if you’re able to do that. Thanks!