Raspberry Pi Agent 2.0


#4

Any chance Remote Access (Desktop) will be returned to 2.0 in the future?


#5

try teamviewer it’s very fast :wink:


#6

All the limitations above will be solved and added back in the following Cayenne releases


#7

@sinhapriyanshushekha @johnc @svein.utne team is working on the release of all features and should be out soon. cant give an ETA.


#8

Thanks for the update. Just a bit challenging for me until further features are released.

I updated several Pis to the 2.0 agent that are in remote locations, connecting via cellular routers. I routinely used the Remote Access feature to check a few local web appliances and to reset devices. I only have local access to the Pis one a month or so.


#9

You can use VNC for remote connection, works great.


#10

Wish I could, but it’s a no go on AT&T’s cellular network. The network provides my Unifi USG WAN link a private IP via a Netgear LB1120 in bridge mode. Seems their doing NAT’ing for all their wireless and mobile network customers.


#11

What are you checking? What are you resetting? You can download lynx which is a text based browser and then SSH to your Pi and view the pages that way. It will display basic web pages but nothing too complex obviously. As far as resetting devices most devices will have alternate ways to reset such as commands. You can SSH to your Pi and then SSH to the device from the Pi and issue the restart command. Hard to give some more suggestions without knowing exactly what you want to do.


#12

No worries. I’m patient and will wait for the features to be returned. I’m access and monitoring Schneider-Electric Solar gear along with a few other network devices. I use SEs Conext Insight to connect to my local combox via https. Again, a hybrid-cloud type solution. It does not allow for remote firmware udpates, ssh terms, etc. I can, however, do those locally via https or command-line ssh. The Cayenne solution was the easiest and most efficient way for me to access the devices in the local net using either https or ssh.

The devices inside the network cannot simply be added to the DMZ , leverage port-fowarding or a dyndns type service. This is a double nat situation with the AT&T wireless/cellular carrier network. Most of the traffic on their regional carrier network comes out onto the net from a single IP. Ever try installing vnc server on your smartphone and trying to access it from another device or your home PC?


#13

Ah, you are using a wireless hotspot. You could install teamviewer. It makes outbound connections so it doesn’t matter what firewalls you are behind.


#14

Yes. That will probably be my workaround for now. I also use goto assist with a small minix win pc. It’s not looked up yet, though. Thanks for the advice from all.


#15

Does the agent automatically update? How can I check the current version? Thanks


#16

any update for mobile app supporting agent 2.x


#17

not yet. but will be out soon.


#18

aw…for those… don’t upgrade yet… if you need these services:

Extensions, Analog and PWM sensors/actuators are not available
Remote desktop is not available
Scheduler is not available
Data History for system sensors (CPU/RAM/Storage) is not available
Mobile application (Android and iOS) don’t support RPi Agent 2.0


#19

@tiendle all this will be available on next release.


#20

I wanted to start my program on boot, so I added one line at the end of .bashrc

python3 /home/pi/Ex-06-CayenneClient.py
But then it failed because there is no output port, so I added one more line.
lxterminal above the last line.
Then it went berserk and opened up hundreds of terminals. What to do?

Problem solved:
lxterminal -e python3 /home/pi/Ex-06-CayenneClient.py

With this line at the end of .bashrc it starts on boot.


#21

@svein.utne the raspberry agent starts on boot everytime, you dont need to do anything.


#22

I think I do.
If I have the dashboard up on the PC, the PI is shown as offline until I run the python3 file.
To be absolutly correct, it does not start at boot. I need to login by Vnc, and when I push the terminal Icon, then it runs the file and then the dasboard comes alive.


#23

okay, sorry, you are using MQTT python, so have a look at this approach by @adam DHT11/DHT22 with Raspberry Pi