Raspberry Pi - all digital outputs unreachable


Hi, I’m new to the whole Raspberry Pi thing and have found Cayenne to be super awesome.

I have connected up the temperature sensor OK but I can’t seem to add a digital output.

Is there something that I need to setup on my Pi.

My Pi is a version Model 3 B and I updated all the system files a couple of weeks ago.

Can someone help me?


Welcome to Cayenne!

Sorry for the delay in getting back to you. If you haven’t figured it out yet, follow the screen shot below and it will create a widget for you. From there just click the button on the widget it creates and the pin will change state.


Hi Adam, thanks for the message.

I have been trying to do what you describe but it isn’t working, whether or not there is anything attached to the breadboard or not.

That’s why I was wondering if there were any other ‘permissions’ type settings that I need to enable?




Hi @paul.trower

This sounds like your Pi might be running the 4.9 Linux kernel, with which webiopi (a component of the Cayenne Pi agent software) is currently incompatible. Could you run the command uname -a to check your kernel version?

If it is showing 4.9, you can switch to the 4.4 kernel with just one command (and a reboot afterwards):
sudo rpi-update 52241088c1da59a359110d39c1875cda56496764

We have an update to the Pi agent in our QA now which should resolve this issue and allow Cayenne to work on both 4.4 and 4.9 in the near future.

If uname -a shows you are already running 4.4, let me know and I’ll continue to help troubleshoot.


Hi, that’s perfect many thanks.




I just wanted to bump this thread to note that we’ve now updated our Pi agent to support the 4.9 kernel (it still supports 4.4 as well). The update was automatic in the background so there is nothing you need to do on your end. Feel free to use rpi-update to move forward to the 4.9 kernel at this point if you’d like!