Raspberry Pi Configuration Settings - limited functionality right now


#1

Hi guys,

Noob post #1

Hardware SPI shows disabled, but it is actually enabled.

Also, when enabling it here, I get the popup:

To change this setting we need to restart your device.
Are you sure you want to change this setting?

…but no change is made and the Pi device does not reset.

Also, I’d like to create an SPI driver for the MAX6675. It shouldn’t be difficult, but I can’t figure out where to put the new .py script.

Craig


#2

Hi Craig,

The settings are still being worked on. Although the SPI issue is definitely a bug. We’ll fix that. Some of the settings that we will allow you to configure are being hidden (such as internationalization options) too.

We released the core features to our invited ‘A-Team’ users, and are working features like Settings in the background.

@eptak passing the question about MAX6675 driver to you.


#3

You can provide us the python script file so we can integrate it the driver in a later release. right now it’s not possible to add your own driver.
You will need to integrate your file into sensor folder from the webiopi sources, add it to init.py in the same folder, then rerun install.