Raspberry Pi Zero installation


#21

Hi @adam,

Sorry about that, here is the output.

Thanks
S


#22

@soubir,

'echo $?"

by requesting $? to be echoed to the console, you are asking for the exit status.

You might need to redo the install sequence again as I thing the exit status will have been written over.

Cheers,

Craig


#23

Apologies again , I am quite new to this, still learning.


#24

That’s probably a legit error code though.

What it is saying is that the script terminated with a fatal error code of 4 (128+4).


#25

Hi @kreggly

I did the whole installation right from the scratch and again got 132 as output. What now from here ?

Thanks
S


#26

I hope we hear frrom @rsiegel and the Pi devs on what is happening in the script. Hopefully that exit code pinpoints the place in th script that is failing and a work around can be offered.


#27

Hi @kreggly,

Any update coming from the team ?

Thanks
S


#28

Hey @soubir, my apologies for the delay. I spoke with the developer, he is looking for one other bit of output based on that error code. Could you run

sudo python3 -X faulthandler setup.py install

and share the output from that command?


#29

Hi @rsiegel,

Here is the output.

Thanks
S
output.txt (4.7 KB)


#30

Thanks, I’ll share it with him.


#31

Hi @rsiegel,

Any updates on this.

Thanks
S


#32

Hi again, thanks for your patience.

The developer I’ve been working with has asked if you could try

python3
then
import _bz2
then
_bz2.__file__

and to see if that outputs a file location, or an import error.

You can use exit() to exit the prompt after trying that.

His current theory is that perhaps the bzip2 package that we’re expecting to be in place isn’t present on the system, you should be able to install it with sudo apt-get install libbz2-dev then try the installation again.


#33

Hi @rsiegel,

Apologies for getting back so late, was travelling for work. I did run the commands and there were errors all over. However, I have found a way to make it work. This is what I have done:

  1. Install the latest Raspian Jessie with Pixel image (not Jessie lite)
  2. Using the console, not SSH
  3. apt-get update
  4. apt-get dist-upgrade , in this process I noticed there is a difference between the jessie lite and pixel version, nearing the end of the upgrade, it asks if you want to upgrade the .conf file , did yes to it and completed the installation. I never received this step using Jessie Lite.
  5. Enabled SSH
  6. Went to Cayenne dashboard to generate the code.
  7. Logged in using SSH and completed the Cayenne installation.

I have tried this on RPiZero and RPiA+ and both worked. I guess for now I am going to use this process as it worked.
I will report back in case I see any issues with this.

Hope this helps you in understanding whats going on. The only challenge with this process is that you can’t use it on a small capacity sd card as you’re installing Pixel and of course the startup and connecting to the network takes slightly longer than Lite.

Thanks
S


#34

It does help quite a bit, and I think if I’m understanding properly this basically boils down to (in your personal experience) that the Cayenne installation isn’t completing on a Pi Zero with Jessie Lite, despite our claimed support for both of these. At least, it might have worked once for you, but the vast majority of times it failed?

As soon as I can get my hands on one of these (they sell out all over the place!) I’ll be sure to try the same so we can knock out any bugs that might be hiding there.


#35

Hi There,

Another update to this, recently, I used a RPi A+ to install Cayenne, again it wouldn’t install on Jessie Lite, however, installed Cayenne at the first attempt on a Jessie with Pixel version, without even update and upgrade.
Not sure if this helps, thought of reporting the finding to you guys.

Cheers
S


#36

It does help, and prompted me to do another round of testing this morning.

I was able to reproduce the Python 3.4.2 error with Jessie Lite on a Model B Gen1 (but not on any Gen 2 or 3). I don’t have a Model A or a Zero at the moment. So perhaps there is something to Jessie Lite + these stripped down models having an install failure.

That said, I was able to resolve the issue by running through this list of commands I’d posted above:

sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install python3.4
sudo apt-get -f install

I had to run through them twice as on the initial run sudo apt-get upgrade and sudo apt-get dist-upgrade were throwing errors which were then resolved by sudo apt-get -f install. But it was necessary to run through the commands again to exhaust the list of available packages, and ultimately grab the needed ones for Cayenne.

So if you’re still seeing that “build for 3.4.2 failed” error message, try running through those commands a couple times, until you’re getting output like 0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded. to indicate that there are no further updates available. Then attempt the Cayenne installation. It appears you don’t need to do anything to clean up the previous failed installation, the installer will work past it OK.


#37

Woot. Woot.


#38

Thx rsiegel.

After trying to install Cayenne on a new Rasberry Pi Zero W, I followed your instructions and it install. It take some time, not sure how long since I walked away and just let it run the install. Not sure if it was the Phone App or Desktop, since I had used them both.