Remote Access issues


#1

So i am totally new to Cayenne, setup my Rpi and can see it in the dashboard.

When I hit remote access i get a the message CONNECTED on the dashboard and in the next popup window it says connecting for a bit then gives me the error Desktop not responding

I have Jessie full etc

What is going on, why does this not connect, I thought this was meant to be easy :frowning: :frowning:


#2

Hi @jody

We might have discussed this in a different thread yesterday, but for the sake for completeness – there was an update to Raspbian Jessie that broke our remote access implementation. I’m happy to say that I tested the final version of the fix for this today and not only does it work again, but the new implementation is much slicker (the graphical desktop view fills your browser, is more responsive, and connects you to the same user session as if you had a keyboard/mouse/monitor hooked to your Pi).

It’s basically ready to go our the door with our next update so I’m sure this bug will be a thing of the past soon.

If you need a graphical remote desktop into your Pi until then, I would encourage you to look at this official Raspberry Pi documentation on setting up a VNC connection so you can do it outside of Cayenne.

If you just need remote access to your Pi’s command line, I’d use SSH


#3

Excellent news, when will you deploy this update?


#4

I don’t have an exact date in front of me, I’ve asked our development team to see if they know more. I’ll update as soon as I hear back


#5

Thanks very much, we await your soonest


#6

Sorry for the late follow up @jody…we’ve released some fixes for remote access a while ago. Let us know how it goes!

Thanks,

~B