Remote controll from desktop


#1

Pi 3 Model B OS V9 debian a0282 raspbian

Web & Android

I cant control my RPi remotely from another desktop, each time I press on “Remote Access” - “Connecting to device, please wait…” runs endlessly. My RAM, CPU and storage usage wont show up either. When using my phone(LGv20 - running Android) I can see RAM, CPU, and storage usage just fine, however when I try to use “Remote Access” app takes me to a browser, and displays message: "We are connecting with the device. Ask the user whose PC you wish to access to click “Share this Device”. After a while message saying “Desktop Not Responding” shows up.

Is there a way to “Share this Device”? (my)

My ssh is enabled, I can remotely reboot or shutdown the RPi from my phone app, or browser that is run on RPi but not from another desktop browser.

Has anyone had similar problem?
Can using stretch be the issue here?
Should I downgrade to Jessie?


#2

Are you running Stretch Lite or Full? Lite does not have VNC installed by default.


#3

Im running full, I also have VNC installed.


#4

The only other thing I can think of is a network config like firewall, etc blocking the traffic. Maybe @rsiegel has some other suggestions?


#5

Might be it, as I am running it on my university network (eduroam). I will try again from my home network later on.
Thanks.

On the other hand, I can control my RPi with other software (VNC viewer) using the same network and the same desktop(the one that cannot control RPi and does not see CPU/RAM/Disk s’ usage) with no issues.