Retropie - Dependencies problem when installing mydevices script


#1

Hi

I have dependencies issue when I run connect script of mydevices on fresh install retropie

Correcting dependencies… failed.
The following packages have unmet dependencies:
expect : Depends: tcl8.5 (>= 8.5.0) but it is not installed
libexpat1-dev : Depends: libexpat1 (= 2.1.0-6+deb8u1) but 2.1.0-6+deb8u3 is installed
libjpeg62-turbo-dev : Depends: libjpeg62-turbo (= 1:1.3.1-12) but 1:1.4.1-2 is installed
xfonts-base : Depends: xfonts-utils (>= 1:7.5+2) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

Anyone have the same problem?


#2

Hi @leal, welcome to the Cayenne Community,

Currently the Cayenne Pi agent supports Rasbpian Jessie and Jessie Lite, so you may want to try one of these OS instead of Retropie.

Alternatively, instead of using the Cayenne Pi agent software to connect your Pi to Cayenne, you could do so via our ‘Bring Your Own Thing’ MQTT API which frees you of the limitations of the Pi Agent software. Have a look at this example which shows connecting a Pi via MQTT rather than the Cayenne Pi agent software.


#3

Retropie is raspbian Jessie.

PRETTY_NAME="Raspbian GNU/Linux 8 (jessie)"
NAME="Raspbian GNU/Linux"
VERSION_ID="8"
VERSION="8 (jessie)"
ID=raspbian
ID_LIKE=debian
HOME_URL="http://www.raspbian.org/"
SUPPORT_URL="http://www.raspbian.org/RaspbianForums"
BUG_REPORT_URL=“http://www.raspbian.org/RaspbianBugs

Do you know how to solve those dependencies?


#4

I’m not sure if this will work or not…but you can try this

sudo apt-get install tcl8.5 xfonts-utils

The other two have newer versions installed so you might be able to get away with it. Let me know if that works.


#5

Hi

I try to run:

sudo apt-get install tcl8.5 xfonts-utils

But not working.

I think when I installed agent for mydevices something goes wrong and apt-get install command not woking at all. I also try to run:

sudo apt-get -f install

And I get same error:
Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… failed.
The following packages have unmet dependencies:
expect : Depends: tcl8.5 (>= 8.5.0) but it is not installed
libexpat1-dev : Depends: libexpat1 (= 2.1.0-6+deb8u1) but 2.1.0-6+deb8u3 is installed
libjpeg62-turbo-dev : Depends: libjpeg62-turbo (= 1:1.3.1-12) but 1:1.4.1-2 is installed
xfonts-base : Depends: xfonts-utils (>= 1:7.5+2) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

thx you for trying to help.

Do you have any further suggestions?


#6

If I run command:

sudo apt-get install tcl8.5 xfonts-utils

before I install agent form mydevices I get less depenencies problems

Reading package lists… Done
Building dependency tree
Reading state information… Done
Correcting dependencies… failed.
The following packages have unmet dependencies:
libexpat1-dev : Depends: libexpat1 (= 2.1.0-6+deb8u1) but 2.1.0-6+deb8u3 is installed
libjpeg62-turbo-dev : Depends: libjpeg62-turbo (= 1:1.3.1-12) but 1:1.4.1-2 is installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies


#7

Hmm looks like the installer doesn’t like that newer version. If you downgrade it will likely break retropi. I would recommend getting a second SD card and installing the full version of Jessie.