Scheduling event


#1

Hi, looking in the community I was not able to find something.
1st
I discovered that if in a scheduling event I set my timezone the event doesn’t work. If I left “default time” it works perfectly. Just my unknowledge or is a bug?

2nd In the event I would like to manage in saturday and sunday in a different way from the working days. Is there any automatic selection? I found a workaround, single event repeated every week but if you want to do a full week scheduling you have to insert 7 events (each in every day) by the number of events per day. long job but it works
thanks
giancky


#2

Hello Sir and Welcome to the Cayenne Community

  1. I always use the default time zone. There were a couple of comments these days that with local time zone there is a bug, so we are waiting for tests and official response
  2. I think that you have to add different events for the weekend days

#3

Thanks for letting us know about this @askfus. Can you elaborate a little bit on the improvements you’d like to see w/ the scheduler? Will help greatly to improve this feature :slight_smile:

@rsiegel can you check if there is issue w/ using a specific timezone?

~B


#4

After running some tests, I think the logic is buggy with anything besides the “Default Timezone” option. For example, I’m in UTC -6 time, so if I schedule an event for 4:00 PM UTC, I’d expect it to fire here at 10:00 AM, but it didn’t. At the same time, if I schedule an event at 10:00AM in Hawaii (UTC -10), I’d expect it to fire at 2:00PM here, but I’m actually seeing it fire at 10:00AM, as if the time zone offset is just being dropped and using local time anyway.

I’ll get this logged for our engineers – in the meantime I think it would be safest to stick with the default time zone option and calculating the offset yourself if your device is in a different time zone than where you’re logging the event.


#5

Thank you very much for this information! :slight_smile: