Trigger Troubleshooting


I too have a problem with a trigger. Setup a digital motion sensor trigger to pin 43 on my Mega. It detects ok on the dashboard, but will not send me an SMS or email.


Are you around where we could do a Skype call so I can see issue in real time?




Were you able to tell anything from the video?




Shoot, just seeing that PM now in my inbox…looking now.




No problem ,thanks for taking the time to do this. It is the second one.



Just replied in PM, let’s continue convo. in PM :slight_smile:


Benny, I’m around tomorrow if you want to do a Skype.



I’m around too :slight_smile:

Does a time on my calendar work?? -->



Ok I booked a time on your calendar.



@ryates2 @gregvmail1 @den_box @rjydev @nicathesenov We’ve been doing some testing trying to get to root issue. For your triggers that are failing, can you try sending the data over different channels and then seeing if the triggers works using the new channel?



Ch 5 is my response (then) channel.
I am triggering on Chs 1,2,3.
It appears only the trigger on Ch 2 is working.



If you have some time, can you check if sending the data over different channels will make the triggers work? Like Ch. 6,7,8,9 for example?



I’m currently unable to physically change the channel because my device is installed in the roof cavity (I could make the change next week).
I’ve just only recently changed it from channel 49 where the detection was sometimes spontaneous to now channel 43 where the sensor seems to work 100% of the time. But no trigger activate.


Ok, so it sounds like you already know the answer here.

I tried Ch 6,7,8,9 and they all worked as the trigger source.

One caveat - they only worked with luxWrite. They would not work with virtualWrite.

I would really like “virtualWrite(ch, value, “digital_sensor”, “d”);” to work.

As an experiment I tried “virtualWrite(6, 1, “lum”, “lux”);” which I believe is equivalent to “luxWrite(6, 1);” And only the luxWrite worked as a trigger. Both widget appear identical. So there is something magic about the luxWrite. I haven’t tried the other write variants yet.

And it may be coincidental, but when I added a lot of widgets, the dashboard was very slow to respond. Almost unusable.



In my case I don’t know if it’s specifically a channel # problem. Because I also have a trigger to fire when my device goes on and offline. These triggers don’t fire either.


Sorry just got a chance to work on this now . . .

Used channel 9

As rjydex, virtualWrite does not work, luxWrite does but . . .only once. After I try to retrigger, it does not work, unless I go to the MyTriggers list and turn it off and then on again, then it works but just once.

Almost there I think.



I hate to say this, but I’m going backwards. I was going to do some workaround code, but Ch 6-9 are no longer working for me with luxWrite. If you haven’t made changes then maybe this isn’t repeatable. It is still working on Ch 2.



@rjydev @gregvmail1 thank you so much for helping to test this out. Good news is I’ve been able to reproduce the issue on my end, just not consistently. We’re looking into this, and I’ll plan to give everyone an update on this beginning of next week!



Thanks Benny and Cayenne developers!

Tryed again this morning, and I am still able to trigger with luxWrite, but only only once unless I “reset” the trigger on the MyTriggers dashboard


@bestes test triggers again.
i began with channel 6 not responding => channel 8 working good at this time !!
Waiting 5 seconds and SMS knock at my phone !
Today Triggers and Schedulling working all together … i must change all Channel to use Triggers and it’s ok !?
Huraaahhh :smile: