Variation of graphic value via ADC MCP 3208


#1

I connected an ADC in the Raspberry, at the input of the ADC a fixed voltage 3.3V.
The Raspyberry is connected to several days, the power and internet there was no drop.
When observing the graph of the eight inputs of the ADC is observed falls in the value of this voltage.
What could cause this?
Could this be the variable that is in the cloud?
Samples are 24 hours.


#2

Hi @heliocastrosp,

I’ve seen this happen with another sensor before that uses a resistor. And I don’t believe this has to do with some variable in the cloud. Is there a way you can monitor the sensor locally on the Pi and also in Cayenne, and then compare to see if there indeed was a drop of value as shown on the Cayenne graph widget? This might help determine where the issue is coming from…

Also, I wanted to connect you with @kwiek . He is doing some very cool things in Brazil :slight_smile:

-B


#3

Olá @heliocastrop,

Um prazer poder colaborar com um brasileiro, eu concordo com o @bestes, de que não é possível que o fato de estar na nuvem possa estar causando seu problema, a ideia do @bestes de fazer um tira teima é a maneira mais facil de ir isolando o problema, se não conectado a rede o problema persiste já eliminaria totalmente a possibilidade de que o problema esteja relacionado com o Cayenee.

Se puder, envie um esquema de como esta conectando sua aplicação, e que código esta usando, toda informação ajuda para tentar analisar com você até chegar a resolução satisfatória do problema.

Aguardo sua informação sobre o resultado sem a conexão com o Cayenne, e também um diagrama e o código usado.

Saudações!

Hello @heliocastrop,

A pleasure to be able to collaborate with a Brazilian friend, I agree with @bestes, that it’s not possible that being in the cloud might be causing your problem, the @bestes idea of taking a test is the easiest way to go insulating The problem, if not connected to the network the problem persists already would totally eliminate the possibility that the problem is related to the Cayenne.

If you can, send a schematic of how you are connecting your application, and what code is using, all information helps to try to analyze with you until you reach a satisfactory resolution of the problem.

I await your information on the result without the connection with the Cayenne, as well as a diagram and the code used.

Greetings!

kwiek


#4

Colleagues of the automation, thank you for the answer.
I did not implement code for Raspberry, I just drag e drop the addition of the ADC MCP3208.
I did this in order to evaluate ADC information over a long period of days, so I could start development along with Cayenne.
But I noticed the falls in the values of the graphs.
In the diagram we can see that I do not currently use sensors, it is converting only the 3.3V voltage, that it is still being supplied by Raspberry.
The print screen we observed that the values drop in the graph does not occur simultaneously, so we can discard the power drop and ethernet connection.
I forward another screen of the graphs observed today.