After log in, stuck on "get started" page


When I log into Cayenne myDevices , on my rpi3, it takes me to a page, “Getting started with myDevices Cayenne” where it announces, “Download on the AppStore” and “ANDROID APP ON Google Play” and “Android coming soon. Notify me.” There I sit and if I click “notify me”, it says it will and still I sit and wait.
Before, when I logged in, I ended up on the same page and after clicking, “notify me” it took me to the dash board.
I can log into Cayenne myDevices on my PC and I get to the dashboeard.
Any help or suggestions will be appreciated.



Hi there,

Welcome to the Cayenne Community. The Android app is not on the google play store yet, it is still in a public Beta phase. You can download the Beta app here.
NEW! Cayenne Android App in Google Play store

You will also need to install Cayenne onto your Pi’s sd card by going through the install process on-screen. If you could remember to expand your sd card prior to Cayenne installation and also the ‘Jessie’ raspbian OS is recommended.

Does this help?




Thank you for the welcome. I was able to get to the dashboard this morning. When I try to log in, now, I am redirected to the ,“Get started…” page and I’m not sure why.
Oh, yes, I did expand the the card prior to installation of Cayenne.



So it would seem that you have not gone through the Cayenne installation on your Pi. sDid you follow the steps in this video?




Yes, I had it up and was adding another device (I’m using a rpi on 7" touchscreen) when I ended up on the “community” page, I think. In trying to get back to the dashboard (I have fingers, a bit, large for the screen, me thinks) I couldn’t find it, so I tried signing in, again and I end up being redirected. Sorry to be such a bother.




I know Benny already did it, but I’ll do it again, welcome!

I’m gonna throw in my 2 cents worth since Benny is taking forever to reply, probably thinks he has a job or something.

Just to confirm you are trying to log in on this page-
I’m concerned you may have fat fingered your username on your initial sign up and now may not know what it is.

It seems you are trying to operate through Raspian. If so this walk through may be of assistance.

If you’re bothering Benny, keep up the good work! But he’ll say you’re no bother 'cause he is a stand up guy.

Hope this helps, if not Benny should be back soon,




Hi Ian,
I needed a smile, thank you! Yes, that is the page I’m trying to log in on. I clicked on the walk-through.pdf and, following the directions, I typed in the url for mydevices, hit enter and I am now looking at a dashboard with a rpi on it… I tried adding a device, a sensor, and could not view all the choices. I tried resizing the screen and found myself on the AppStore screen. I’m using Iceweasel and I’m going to see what happens in Web Browser.



Live and learn. Do we have a choice? Thank you, Ian, the link you sent does state, “open Web Browser” it seems I’m in. If not, perhaps I’ll bother Benny some more. Thanks, again to both of you! Great name Ian; its my conformation name. Cheers!



Great to hear!
You may not be able to scroll to all the sensors because of compatibility problems. But you can start entering their names in the ‘device name part number’ box and it should come up on the screen where you can click on it.




The Cayenne interface isn’t specifically compatible with any of the Raspian browsers, I found that Epiphany seemed to be the least troublesome of the lot, Ice Weasel was my first choice also. But in the end I’m running all 5 of my RPi’s headless.

Please do.

Thank you. I’m named after one of my fathers college fraternity brothers. A gentleman named Ian Eric Michael Donavan.