Bug Filed on 12-07-2015: Whoops I've broken the dashboard


1.online dashboard

2. pressed Reset dashboard to default button … result multiple copies of widgets see attached, tried logging out & rebooting pi but now each time I log on I get the multiple widgets, cannot find a way to resolve this issue.



Hi Toshi,

Thanks for attaching the pic. Thought we fixed this issue before the A-Team release, looks like it came up again.

Let you know when we get this resolved!




Also receiving the same issue with my page filled with icons, not sure if it is related but cannot add sensors (temperature or inputs) anymore



Regarding this multiple widget issue, I just tried a fresh install on my pi, but still the issue persists, clearly this means I cannot do any testing etc, in reality I have to take a trip for a couple of days (back on Friday) but in the mean time can you suggest any coarse of action I can take to resolve this?

Oh and when I did the fresh install I did notice the following … so is sh: 0: getcwd() failed a problem ?

Webiopi install finished
sh: 0: getcwd() failed: No such file or directory
[ ok ] Restarting WebIOPi: webiopi.
sh: 0: getcwd() failed: No such file or directory
[ ok ] Restarting myDevices: myDevices.




Hi again Toshi,

I’m sorry you are experiencing these issues… The text you pasted shouldn’t be a problem.

Does the issue only persist when you click the ‘Reset dashboard layout to default’? If so, then the course of action I would take is to not click it. Another course of action is to get a clean SD card with Wheezy installed and get a fresh install of myDevices Cayenne onto the Pi. Also, add the sensors manually from the dashboard GUI (thought you might be adding directly from the Pi?). Here is list of sensors we have fully tested link

When you get back from trip there should be fixes in place…

Thanks for hanging in there, we appreciate it!




Sorry your misunderstanding the issue, the jpg I posted is just a snap shot of the screen it scrolls on and on with the same same stuff, I am not pressing reset to default, and I deleted that pi wiped my sd card and reinstalled wheezy then followed original instructions to install mydevices, even after all this when I log on to the mydevices Web page I get the same screen back, with the multiple widgets, I cannot add it delete anything or even change to the GPIO screen, its just completely screwed.



Also got the same thing, multiple icons, even the remote access, reset etc pane is also duplicated.
I found that the reset button removes majority of the icons only to start replicating again



@toshibass101 @booysenc We just deployed some fixes, the issue you were experiencing with the dashboard ‘breaking’ is hopefully fixed now.

If you find it not fixed, I may want to see if you would allow us to debug with your account, since we were having issues reproducing…

Thanks for reporting these issues to us!




Did you remove the reset button? that was my saving grace to sort of refresh the dashboard. Still shows pages and pages of icons. I’ve tried to remove buttons or sensors but even this is a struggle (sometimes re-appearing)
Silly question but I don’t need to change anything on my pi, this is online related?



Hi Chaun,

We removed the Reset button. That was originally used so we can rapidly test various widgets and configurations, and we found it caused some problems (related to issue you are experiencing)…which apparently is not fixed yet.

I’ll reach out privately to see if we can debug directly on your Pi device to see what the issue is.

Not a silly question! I just don’t have an answer yet.




@toshibass101 @booysenc We deployed another fix. Please let us know if you experience the issue.



Bug Filed on 12-11-2015: Whoops I've broken the dashboard continued