Bug Filed on 12-13-2015: Failure to install myCayenne

Try putting ‘sudo’ in front of it.

That’s probably why it errored out on you. Do a sudo su and run that same command or just add sudo in front of it and it should install without error.

Ok, I used sudo and I got this:

Wed 16 Dec 19:29:25 UTC 2015 Install finished

I guess that worked. Please document the sudo requirement.

I’m not sure how you went about your install but it is documented in the add new device section. Maybe where you were looking it is not there, might want to include that.

I am getting similar error and installation fails - “Can not install for python 3.2.3: missing development headers”

These are Pi 2B’s and python 2 and 3 are both installed.
Any suggestions?

Welcome to Cayenne!

Only Jessie Full and Jessie Lite are currently supported. you can try to use the command “sudo apt-get install python-dev” to install the dev headers though. That worked for some people.

Thank you for the suggestion - I did that but did not help - fyi.