Device Icon save fails

Hi all,

Over the long Easter weekend I have been building an MQTT connected version of my cheap n cheerful LoRa gateway for myDevices Cayenne (I have built versions of my LoRa gateway for a couple of other vendors’ SaaS IoT offerings so hopefully am not a newbee).

As part of the getting to know how Cayenne works process I have created an MQTT console client application (I’m using .Net Core 2.X C# and MQTTnet but that really doesn’t matter for this query).

My MQTT client connected OK so I have the basics sorted.

I created a couple of devices and in the “configure” page for my first device I noticed I could change the associated icon so I tried changing it to a “Base Station”.

This process fails every time with a “could not update device settings” I have tried different browsers, resetting my dashboard, logout/login etc. (std. end luser fault finding steps).

Am I doing something stupid?

Is being able to change the device Icon a feature of a paid subscription? If so the error message isn’t very helpful :slight_smile:

Bryn

T: @KiwiBryn
G: github.com/KiwiBryn
B: blog.devmobile.co.nz

Thanks for reporting this bug. We will have it fixed.