DHT11/DHT22 with Raspberry Pi


#271

What do you mean?

And for the DHT library to work you’ll have to put it somewhere that Thonny knows about it. When you ran in in the terminal it looks like it worked.


#272

Okay looking at the terminal, it looks like the pi is sending information. However, my cayenne dashboard has not yet populated. It still says waiting for board to connect.


#273

Try re-copy/paste the credentials. Maybe they are wrong? Next thing to try is a a packet capture to make sure it’s sending data, and the right data. Have you ever done a packet capture?


#274

Okay you were right the client ID was off by one letter. I now have a dashboard.


#275

now follow this tutorial and see if you reading from DTH11 https://learn.adafruit.com/dht-humidity-sensing-on-raspberry-pi-with-gdocs-logging/overview


#276

Hello shramiksalgaonkar and adam, thanks for all your help. It’s working now and I could not be happier. on to the next project.


#277

thanks for all your help. my code is working now with raspberry pi 3 and dht-11.


#278

Thanks for posting this. Been struggling with DHT22. Now all working. As for 'Waiting for board to connect" I had the same issue.

However the only real issue was my patience, stopped tried again, then realised client ID was changing every time, tried again, had a beer and it worked. :smiley:

Good topic