DS18b20 not appearing in dashboard anymore


Yes i did. i used sd formater and imagewriter to prepare the SD.
and a new install code.


Usually when disconnected numbers are displayed it means there is some hiccup in the wiring. You checked if it was plugged in correctly to GPIO 4?

What agent version do you have? (Check configuration settings on dashboard)



i have tried almost every way possible with the wiring.


which 1-wire sensor are you using? You have resistor? Maybe send a pic?

This is weird because you say it was working before and all of a sudden stopped working.


as i said it detected it by itself the first 3 times. did not change anything on the wiring. just restarts due to the disconnected numbers.


Might take a look at the RPi itself and see what it is getting from the sensor.

cd /sys/bus/w1/devices/
cd 28-"put your serial here"
cat w1_slave

if you get something that looks like this,
25 01 4b 46 7f ff 0b 10 65 : crc=65 YES
25 01 4b 46 7f ff 0b 10 65 t=18312
the last number, 18312 in my case, is the temp in milli-Celsius. So in my case it is 18.312°C in my back yard.

At least you will know if the sensor and RPi are working together.

My heartfelt thanks to pyromd76 over on http://faradaysclub.com/?p=907 for lernin’ me on this.


Need help with DS18B20
How to make ds 18b20 works...?
D18B20 - what should i write into the "slave" field
Getting -381 degrees on the one wire sensor

well… i dont have those numbers.
i get to:
cd /sys/bus/w1/devices/
and there is only w1_bus_master1

and i guess that means that it cant find the sensor.



Welcome to the group!

That is disappointing. I wish I could email you another sensor to try. Other than checking to make sure you don’t have a break in the path from the RPi through the breadboard to the sensor, I’m out of ideas.





when i use the LS command i get a bunch of other numbers that all start on “00-” and they change for everytime i try the command


I have seen that behavior before and it was because I had the sensor wired wrong, reversed polarity I think :blush: . Fortunately when I corrected my mistake all worked well.

Things look correct to me in your photo though…


something seems wrong anyways… cause my sensor is getting warm. as if it was just wrong polarity.


If it is getting warm, it does sound like reversed polarity to the 18B20. Weird that things worked before.

Do you have a VOM available? Might check the resistor?

I would pull every thing apart at this point, replace what I could (jumpers, resistors, breadboard…) and try again. I’m fortunate enough to have spare Pi’s and 18B20 also, but I understand that isn’t the case with everyone.

Sadly I need to go to work, so I won’t be able to check on your progress, good luck,



as i switched polarity i got a bunch of other numbers starting with “93-” what ever that means.


I can’t believe I said that. To the more than a 1000 of my co-workers that were laid-off on Thursday, my apologies.

“Fortunately, I need to go to work.” might have been a more appropriate thing to say.

Have a great day everyone, I’ll be back in a bit,



Slightly on topic here, I have mentioned this before but worth flagging as someone may want to tinker with these ideas:
To super simplify the DS18B20 etc, I am pretty sure you can enable the internal software controlled WPU resistor on the main brain of the Pi and this would make things really nice as you just need to plug the three wires direct onto the GPIO with no fiddling about…
Thought is there anyway for anyone who knows how to poke the registers internal settings. I think I even saw a choice of currents ? The Scratch GPIO people do this for digital inputs. It means that just a microswitch is needed and no pull-up or pull-down resistors etc.
I know the 4k7 is not expensive but I use this trick with other micro’s and it works a treat for DS18B20, the I2c bus, and for energising other simple two wire sensors…
~ Andrew


Check out this tutorial too. Maybe there was misplacement of resistor or something. Or maybe the sensor was fried somehow?






Just curious, have you had any luck solving your challenges with the DS18B20?



Hey Emil,

I’m switching this topic to the “Need Help with my Project” category.



Hello guys. I solved it with a new sensor.
still did not automatically show up in the dashboard but by manually adding it worked.



Glad to hear you’re making progress! Sorry about the other sensor, but at least you’re back online.

Not sure what to tell you about the lack of discovery, I’m sure @bestes will chime in.