Installing from fresh


Can this not be done via wifi pretty sure i have repaired an install via wifi. Do i need to be root? I know this a newbie question but cannot get it to install even manually it downloads the package but fails to run it properly "no such directory


Hello Sir,
What kind of device you try to install? Raspberry?
I think that you have to be root :slight_smile:


Hi there yes its raspberry in root i have other apps working my lights atm, think i may give up here tbh fi ding it very problematic, when i can just press a button and it works, still cannot install ive got the package but wont install, tried through the app and it just sits on part 1 and does nothing i have rooted the device and still nothing, im not using lan cable im using wifi which was fine last time i had it running i know this because ive no access to wired connection my device is inside a unit where it needs to be.


Hi @dar_c,

If you’re having trouble installing a Raspberry Pi through the mobile app, I would recommend to install it via the manual command line install instructions on the Web Dashboard. This way if something goes wrong during install, you’ll be able to show the command line output to us to help you troubleshoot. And once you have the install completed OK, you can use the mobile device to interact with the Pi on Cayenne if you prefer.

I noticed in your original post you mentioned that you already tried a manual install, so I won’t post the steps here. You mentioned a “no such directory” error: could you show us the full output from running the install command so I can see the context in which you got this error? Let me know if I’m not being clear.


root@FishPi:~# bash
dir exists
grep: /etc/myDevices/AppSettings.ini: No such file or directory
Invite code does not exist but directory does so we will add invite code line 14: /etc/myDevices/AppSettings.ini: No such file or directory line 15: /etc/myDevices/AppSettings.ini: No such file or directory line 16: /etc/myDevices/AppSettings.ini: No such file or directory
Failed to stop myDevices.service: Unit myDevices.service not loaded.


Did you rename the file? it should have a bunch of characters after it like The part after rpi is the invite code that you are getting errors about.


Tried them twice will have to give it another go


Just following up here to see if you got the install to work?