Offline since activating wifi



Web and iOS

Just got the wifi working and as soon as it associated with he router iOS shows device offline when trying to use buttons. Reboot and shutdown didn’t work. I had unplugged the LAN to use the wifi first. then turned off wifi and plugged in LAN and still offline.



Hi @wmontg5988!

Have you confirmed that your Pi3 is connected to the WiFi? If I’m understanding correctly, you are switching your Pi3 back and forth from WiFi to ethernet?



@bestes I turned on wifi and it associated with the ssid of my router, then I unplugged the Ethernet. That’s when it started showing offline. Reboot and no change. Turned off wifi switched back to Ethernet and still offline. Previously I reserved the MAC address for the RP3 in the router under the static IP address that I placed in the config file. On the desktop the Ethernet and wifi both show the proper IP address and associated with the router. 24 hours and still the same.


Just tried adding the device again and get error chmod’ing failure. Maybe it’s just because I’m adding the same device.


Tried this and it worked

Sudo service networking stop
Sudo service ifplugd stop

Sudo dhclient-v eth0 this restarted the Ethernet service I assume. Trying to use the wifi again knocked me off the internet again so I’m just going to hold off on wifi for now and run a cable. Maybe the wifi service interferes with a client service or is missing a service.