Unable to reach arduino.mydevices.com:8442 - putty advice


#10

@o11, did popping this on the DMZ sort you out?

Cheers,

Craig


#11

Im having problems with this aswell it keeps sending Connecting to arduino.mydevices.com:8442
to the serial monitor, Im also on a local network.


#12

Check your router settings to allow outbound traffic on port 8442. Most routers will allow outbound traffic by default, but on corporate networks, or ultra paranoid folks like me may tweak the settings to disallow any traffic that isn’t explicitly defined.

As mentioned above, you can try putting your device IP in the DMZ temporarily and if it works, then figure out how to allow outbound on 8442.

Cheers,

Craig


#13

Thanks for the answer but Im afraid putting the device ip in the DMZ didnt work either :S

[0] Using static IP
[1300] My IP: 192.168.1.2
[5001] state 0, tconn 0
[5001] Connecting to arduino.mydevices.com:8442
[6833] Connect failure
[10002] state 0, tconn 0
[10002] Connecting to arduino.mydevices.com:8442
[11837] Connect failure
[15003] state 0, tconn 0
[15003] Connecting to arduino.mydevices.com:8442
[16837] Connect failure
[20004] state 0, tconn 0
[20004] Connecting to arduino.mydevices.com:8442
[21839] Connect failure
[25005] Connecting to arduino.mydevices.com:8442
[26828] Connect failure
[26829] state 0, tconn 0
[30006] Connecting to arduino.mydevices.com:8442

This is what appears in the serial monitor with debug on


#14

And now I changed IP and it worked for some seconds

And then back to the same

Well nevermind, Im gonna forget this site like all the other iot sites … It looks nice but it does nothing.


#15

Hi @Volkun,

It’s likely a network configuration issue on your end, I’m sure we can get to the bottom of it. Presuming you have a computer of some sort on your network (and that computer can ping your Arduino), we can try to verify your connection to arduino.mydevices.com

If it is running OS X or Linux, you can run

telnet arduino.mydevices.com 8442

on your command line.

If things are working, it will disconnect you right away, but you’ll get a message like “Connected to arduino.mydevices.com” first.

If you’re running Windows, you can download PuTTY: http://www.chiark.greenend.org.uk/~sgtatham/putty/download.html to make the same test. You’d be looking for these settings:

Once you click ‘Open’ there, if you get a popup with ‘Connection closed by remote host’, then your computer is able to communicate with arduino.mydevices.com on port 8442. If you get a blank black window and no popup message, you’re blocked for some local reason that we can continue to help you figure out.


Wifi shield connection problem with Cayenne
Arduino board connection issue
Troubleshooting Pi Showing Up as Offline in Dashboard
WifiShield with arduino uno compiling error
Arduino and rpi3 offline
#16

I had same issue. I downloaded PuTTY and I got “Fatal error” message. Then I searched how to open certain ports on my router and because I am using WDS system, I had to add port 8442 to both of the devices (router and the bridge). That solved this problem.

Here is how you can add ports with TP-Link routers: http://www.tp-link.com/lk/faq-72.html

To check if your device is even on the device list, go to DHCP, DHCP Client List and search for ESP device.

Hope this would help somebody…


#17

Sorry, for acting like a jerk, I guess you people find loads of people here. It seems like the port is blocked, I did exactly as you told, a blank black window pops for a second and disappears.

Also, today Ive tried to connect an arduino (mega) and I cant even seem to manually set an ip, it always prints
[0] Using static IP
[1300] My IP: 0.0.0.0
[5001] state 0, tconn 0
[5001] Connecting to arduino.mydevices.com:8442

And gets frozen here and doesnt do anything more.

Thanks in advance and sorry for being a jerk.
Volkun


#18

Have you tried to connect your computer to this server. Use telnet or putty.
If you have OSX or Linux try to type on terminal:
telnet arduino.mydevices.com 8442


#19

I have done this, black screen pops for 1 second and disappears. The port is indeed blocked it seems :S


#20

Have you a firewall in the system, in the router, or Antivirus, or program that block the in/out connections? Have you a direct access to the internet or behind server?


#21

I am a noob in this stuff, so what I will say will probably make no sense…

Im using an arduino mega connected to an ethernet shield W5100, which is directly connected to the router. I do have an antivirus on the pc but I dont think it is blocking any connections let me try.


#22

By the way the ip, 0.0.0.0, I didnt set that like that, I did try setting other ips but everytime I I upload it always shows up as 0.0.0.0 no matter what


#23

I managed to unblock the port in my router, in putty, now it says connection to host closed. And some 2 green brackets appear in the black window, I could also set the IP for the arduino mega it stopped showing 0.0.0.0 now it actually displays the IP, I could connect it to the site finally after consecutive failures and success in the serial monitor. Thanks for the putty advice!

For anyone that has this same problem with arduino mega, check that if the ICSP pins are correctly connected and if the pins you are using are connected to the 50,51,52 and 10 or 53 for ethernet and 4 for sd card.


#24

HI,
I have the same problems . Connect Mega 2560 over Wifishield upload sketch and got the message wifi connected Ip… and then
[519625] Connecting to arduino.mydevices.com:8442
[530627] Connecting to arduino.mydevices.com:8442
[540631] Connecting to arduino.mydevices.com:8442
[550634] Connecting to arduino.mydevices.com:8442
[560637] Connecting to arduino.mydevices.com:8442
[570640] Connecting to arduino.mydevices.com:8442
[580642] Connecting to arduino.mydevices.com:8442

and on dashboard : waiting for board to connect

With putty I got the message : Connection closed by remote host’

Tried many times to connect , upload sketch again and tried to open ports but every time the same.


#25

Can you try editing CayenneDefines.h and use the ip address instead, 54.86.250.218.

Some Arduinos don’t handle DHCP so well.

Cheers,

Craig


#26

I tried to edit CayenneDefines.h with texteditor and change arduino.mydevices.com to 54.86.250.218 . But the same problem. Should I include CayenneDefines.h into the sketch?


#27

The message should now be:

Connecting to 54.86.250.218:8442.

Please confirm.


#28

Yes message is Connecting to 54.86.250.218:8442. But in a loop and the dashboard is loading


#29

So if it continues to say connecting, you can change it back, it’s not a dhcp issue.

What wifi shield model are you using?

Can you share your sketch so someone else can verify?

Cheers,

Craig